Opened 10 years ago

Closed 10 years ago

#1181 closed defect (fixed)

Oscam crashes on click on kill client

Reported by: lolax Owned by:
Priority: Please fill in Component: General
Severity: medium Keywords:
Cc: Sensitive: no

Description

Revision

3714 an newer

Issue Description

Oscam crashes on kill client button on the webif

2010/10/30 22:14:09 403D7B80 c user-cccam (1830&000000/EF10/92:176E): found (300 ms) by hdplus (of 1 avail 1) - RTL HD
2010/10/30 22:14:11 40398B80 h thread        0 killed!
2010/10/30 22:14:11 40398B80 h FATAL ERROR: could not find client to remove from list.


Change History (14)

comment:1 by alno, 10 years ago

if you go with mouse over the icon the URL should looks as follow: http://<IP>/status.html?action=kill&threadid=1078065680
can you confirm this? Otherwise please post the [webif] part of your config

comment:2 by _network, 10 years ago

i think %d in printf is integer.
so its not always possible to print out the pointer on 64bit systems.
maybe that the issue here.
%p or %ld should work.

comment:3 by alno, 10 years ago

Thanks for the hint - I have changed this. But I believe that this is a issue of old Rev. I have moved the href parameter from csidx to threadid some time ago. There ara some Revisions wich won't work properly because I wrongly wrote the ptr instead the threadid to the template. Also guys with external templates can get a problem.

comment:4 by lolax, 10 years ago

with the rev 3783 the button doesnt work

its a link like this
http://ip:83/status.html?action=kill&threadid=1295816

but nothing happens, there is nothing in the log

comment:5 by alno, 10 years ago

I have added some log output for kill, restart and reset stats

comment:6 by lolax, 10 years ago

how can i reset stats?

Last edited 10 years ago by lolax (previous) (diff)

comment:7 by alno, 10 years ago

bei clicking the value in column LB Value (as shown in the mousover tooltip)

comment:8 by lolax, 10 years ago

Resolution: fixed
Status: newclosed

everything works with 3833

comment:9 by lolax, 10 years ago

Resolution: fixed
Status: closedreopened

with rev 3850 the same problems. oscam crashes on clientkill

2010/11/08 10:16:48 413B4B80 c dream (1830&000000/EF10/92:C05D): found (293 ms) by hdplus (of 1 avail 1) - RTL HD
2010/11/08 10:16:52 413BBB80 c dream2 (1830&000000/EF74/92:89CC): found (294 ms) by hdplus (of 1 avail 1) - SAT.1 HD
2010/11/08 10:16:55 413B4B80 c dream (1830&000000/EF10/92:1C9D): found (300 ms) by hdplus (of 1 avail 1) - RTL HD
2010/11/08 10:16:59 40398B80 h thread 413B4B80 killed!
2010/11/08 10:16:59 413BBB80 c dream2 (1830&000000/EF74/92:F273): found (295 ms) by hdplus (of 1 avail 1) - SAT.1 HD
2010/11/08 10:17:01 40398B80 h Client dream killed by WebIF from 192.168.69.85

comment:10 by cybernando, 10 years ago

Bug is also in rev 3862 !!!

comment:11 by alno, 10 years ago

which type of client !!!!!

comment:12 by cybernando, 10 years ago

cccam client

comment:13 by schlocke, 10 years ago

Can't reproduce this. Please send log with debug -d129

comment:14 by Deas, 10 years ago

Resolution: fixed
Status: reopenedclosed

no log from current version => closed...

Note: See TracTickets for help on using tickets.