Opened 10 years ago

Closed 10 years ago

#1203 closed defect (fixed)

readnano = [path]filename in oscam.server is not working in any version

Reported by: luckylucke Owned by: merek
Priority: critical Component: General
Severity: high Keywords: readnano
Cc: Sensitive: no

Description

Revision

<tried even in last trunk 3815>

Issue Description

< readnano = [path]filename not working>

this is my config that writes nanos to a file in oscam.server

[reader]
 label = mylabel
 protocol = internal
 device   = /dev/sci1
 cardmhz = 600
 group =1
 EmmCache = 1,3,15
 savenano = all
 ecmcache = 1
 # readnano = /var/tuxbox/config/write.emm
 Fallback = 0
 caid     = XXX

This writes nano file both .bin and .txt in /var/tuxbox/config/ directory ..
I rename the file (I have tried to rename both in order) write.emm..

After writing these data, I restarted oscam with the config below. (in oscam.server)

[reader]
 label = mylabel
 protocol = internal
 device   = /dev/sci1
 cardmhz = 600
 group =1
 EmmCache = 1,3,15
 ecmcache = 1
 readnano = /var/tuxbox/config/write.emm
 Fallback = 0
 caid     = XXX

.
.

and this is the log in oscam.txt

2010/11/03 16:59:14 3ABCD000 s root version=1.00-unstable_svn, derived from build #3798, compiled for=mips-tuxbox-linux, nice=-1
2010/11/03 16:59:14 3ABCD000 s client max. idle=120 sec, debug level=0
2010/11/03 16:59:14 3ABCD000 s max. logsize=1024 Kb
2010/11/03 16:59:14 3ABCD000 s client timeout=5000 ms, fallback timeout=2500 ms, cache delay=0 ms
2010/11/03 16:59:14 3ABCD000 s auth size=4800
2010/11/03 16:59:14 3ABCD000 s services reloaded: 0 services freed, 0 services loaded
2010/11/03 16:59:14 3ABCD000 s userdb reloaded: 0 accounts freed, 1 accounts loaded, 0 expired, 0 disabled
2010/11/03 16:59:14 3ABCD000 s signal handling initialized (type=sysv)
2010/11/03 16:59:14 3ABCD000 s XXX service-id's loaded
2010/11/03 16:59:14 3ABCD000 s can't open file "/var/tuxbox/config/oscam.tiers" (err=2), no tier-id's loaded
2010/11/03 16:59:14 3ABCD000 s can't open file "/var/tuxbox/config/oscam.provid" (err=2), no provids's loaded
2010/11/03 16:59:14 3ABCD000 s 0 lengths for caid guessing loaded
2010/11/03 16:59:14 3ABCD000 s monitor: initialized (fd=6, port=988)
2010/11/03 16:59:14 3ABCD000 s camd33: disabled
2010/11/03 16:59:14 3ABCD000 s camd35: disabled
2010/11/03 16:59:14 3ABCD000 s cs378x: disabled
2010/11/03 16:59:14 3ABCD000 s newcamd: initialized (fd=7, port=1212, crypted)
2010/11/03 16:59:14 3ABCD000 s CAID: XXX
2010/11/03 16:59:14 3ABCD000 s provid #0: 000000
2010/11/03 16:59:14 3ABCD000 s cccam: disabled
2010/11/03 16:59:14 3ABCD000 s radegast: disabled
2010/11/03 16:59:14 3ABCD000 s http thread started
2010/11/03 16:59:14 3ABCD000 s creating thread for device /dev/sci1 slot 0
2010/11/03 16:59:14 3ABCD000 s waiting for local card init
2010/11/03 16:59:14 2B637500 h HTTP Server listening on port 3333
2010/11/03 16:59:14 2CF37200 r reader thread started (thread=2CF37200, device=/dev/sci1, detect=cd, mhz=357, cardmhz=600)
2010/11/03 16:59:14 2CF37200 r card detected
2010/11/03 16:59:16 2CF37200 r ATR: XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX 
2010/11/03 16:59:17 2CF37200 r Maximum frequency for this card is formally 6 Mhz, clocking it to 6.00 Mhz
2010/11/03 16:59:18 2CF37200 r detect irdeto card
2010/11/03 16:59:18 2CF37200 r caid: XXX, acs: X.XX, country code: XXX
2010/11/03 16:59:18 2CF37200 r providers: 4, ascii serial: XXXXXXXXXX, hex serial: XXXXXX, hex base: XX
2010/11/03 16:59:21 2CF37200 r active providers: 4 (XXXXXX,XXXXXX,XXXXXX,XXXXXX)
2010/11/03 16:59:21 2CF37200 r found cardsystem
2010/11/03 16:59:21 2CF37200 r ERROR: EMM read from file /media/hdc1/depo/oscam/write.emm NOT processed correctly!
2010/11/03 16:59:22 2CF37200 r entitlements for provider: 1, id: XXXXXX
2010/11/03 16:59:22 2CF37200 r chid: XXXX, date: 2010/11/03 - 2010/12/03
2010/11/03 16:59:22 2CF37200 r chid: XXXX, date: 2010/11/03 - 2010/12/03
2010/11/03 16:59:22 2CF37200 r chid: XXXX, date: 2010/11/03 - 2010/12/03
2010/11/03 16:59:22 2CF37200 r chid: XXXX, date: 2010/11/03 - 2010/12/03
2010/11/03 16:59:22 2CF37200 r chid: XXXX, date: 2010/11/03 - 2010/12/03
2010/11/03 16:59:22 2CF37200 r chid: XXXX, date: 2010/11/03 - 2010/12/03
2010/11/03 16:59:29 2CF37200 r [irdeto-reader] ready for requests
2010/11/03 16:59:29 3ABCD000 s init for all local cards done
2010/11/03 16:59:29 3ABCD000 s anti cascading disabled

I have tried in different trunks and different crosscompiled filed (mipsel and ppc)
All same..
Paths and the filenames were given in config files true..
Error is EMM read from file /media/hdc1/depo/oscam/write.emm NOT processed correctly''

When the issue occurs

<when I wanna write the nanos to the card from oscam's presaved file>

How the issue is reproducable

<Please fill in>

<Don't forget to ATTACH (not post here) a log file of oscam in debug mode (start oscam with -d255)!>

Change History (11)

comment:1 by luckylucke, 10 years ago

In the subject session I wrote now instead of NOT ..
Sorry.

That must be NOT WORKING..

comment:2 by Deas, 10 years ago

Summary: readnano = [path]filename in oscam.server is now working in any versionreadnano = [path]filename in oscam.server is not working in any version

comment:3 by luckylucke, 10 years ago

Why nobody deals with this ERROR ?

comment:4 by merek, 10 years ago

Owner: changed from luckylucke to merek
Status: newassigned

comment:5 by merek, 10 years ago

ok, looks like that the emm's arent't written on oscam start because the reader was not ready, so you have to send SIGUSR2 to oscam process. The emm should be written to the reader after card_info was called and the card was initialized correctly. btw. you see the written emm only in i/o logging as we call reader_emm and this function dosen't log anything.

comment:6 by luckylucke, 10 years ago

:( Still couldn't fix it.. Working on

comment:7 by FilipeAmadeuO, 10 years ago

Any news on this ?

comment:8 by Admin, 10 years ago

_network did a fix on this in [4249]. The EMMs should now tried to be written AFTER the line "ready for requests". So it should be the correct timepoint. However, if the card doesn't see your EMM as valid, you will still get the error message from above (the message says that it read the file ok but writing to the card somehow failed).

comment:9 by FilipeAmadeuO, 10 years ago

Still not working on 4397. I get in the log:

2011/01/10 20:19:02 2BD034B0 r Protocol: Received block I(1,0)
2011/01/10 20:19:02 2BD034B0 r answer from cardreader zoncard:
2011/01/10 20:19:02 2BD034B0 6F 00
2011/01/10 20:19:02 2BD034B0 r [nagra-reader] result not expected (6f != 84)
2011/01/10 20:19:02 2BD034B0 r [nagra-reader] nagra2_do_emm failed
2011/01/10 20:19:02 2BD034B0 r ERROR: EMM read from file /etc/tuxbox/config/zoncard_emm.log NOT processed correctly!
2011/01/10 20:19:03 2AAC6850 s init for all local cards done

comment:10 by Admin, 10 years ago

Your card says that it couldn't process this EMM. In my opinion, this is not an OSCam error.

comment:11 by Admin, 10 years ago

Resolution: fixed
Status: assignedclosed

According to forum post this works.

Note: See TracTickets for help on using tickets.