Opened 10 years ago

Closed 10 years ago

#1230 closed defect (fixed)

>= r3844 : loadbalacing bug ?

Reported by: boubaris Owned by:
Priority: major Component: General
Severity: medium Keywords:
Cc: Sensitive: no

Description

Revision

Issue Description

<Please fill in>

When the issue occurs

<Please fill in>

How the issue is reproducable

<Please fill in>

http://www.www.streamboard.tv/wbb2/thread.php?threadid=30001

I've a strange behaviours about loadbalancing in r3844

For testing I've setup 2 remote servers with the same card and about same response timing (about 200 mSec)

If I disable LB, sometimes I get CW from server A, sometimes from server B.
Ok, it's correct.

2010/11/08 21:17:52 2C0D84E8 c dvbapi_qboxhd (0919&000000/2FED/B7:7B44): found (206 ms) by d_camd35 (of 3 avail 3)
2010/11/08 21:18:02 2C0D84E8 c dvbapi_qboxhd (0919&000000/2FED/B7:E707): found (205 ms) by remote_camd35 (of 3 avail 3)
2010/11/08 21:18:12 2C0D84E8 c dvbapi_qboxhd (0919&000000/2FED/B7:7229): found (209 ms) by remote_camd35 (of 3 avail 3)
2010/11/08 21:18:22 2C0D84E8 c dvbapi_qboxhd (0919&000000/2FED/B7:6F04): found (199 ms) by d_camd35 (of 3 avail 3)
2010/11/08 21:18:32 2C0D84E8 c dvbapi_qboxhd (0919&000000/2FED/B7:E7C6): found (205 ms) by d_camd35 (of 3 avail 3)
2010/11/08 21:18:42 2C0D84E8 c dvbapi_qboxhd (0919&000000/2FED/B7:7CC5): found (206 ms) by d_camd35 (of 3 avail 3)
2010/11/08 21:18:52 2C0D84E8 c dvbapi_qboxhd (0919&000000/2FED/B7:F1FE): found (208 ms) by remote_camd35 (of 3 avail 3)

Now I enable LB and I use lb_weight to set a preferred server (A)
oscam.conf: lb_mode=1

oscam.server:
[reader] (server A = "remote_camd35")
....
lb_weight = 200

[reader] (server B = "d_camd35")
....
lb_weight = 100

And works fine: CW are received always from server A

But if I shutdown server A, cw are received from server B WITH VERY HIGH response timing, about 10x (> 2000 mSec)

2010/11/08 21:24:32 2B0D84E8 c dvbapi_qboxhd (0919&000000/2FED/B7:3530): found (207 ms) by remote_camd35 (of 1 avail 2)
2010/11/08 21:24:42 2B0D84E8 c dvbapi_qboxhd (0919&000000/2FED/B7:371C): found (207 ms) by remote_camd35 (of 1 avail 2)
2010/11/08 21:24:52 2B0D84E8 c dvbapi_qboxhd (0919&000000/2FED/B7:D28F): found (209 ms) by remote_camd35 (of 1 avail 2)
2010/11/08 21:25:02 2B0D84E8 c dvbapi_qboxhd (0919&000000/2FED/B7:E5AD): found (208 ms) by remote_camd35 (of 1 avail 2)
SHUTDOWN "remote_camd35"
2010/11/08 21:25:15 2B0D84E8 c dvbapi_qboxhd (0919&000000/2FED/B7:BD05): found (2540 ms) by d_camd35 (of 1 avail 2)
2010/11/08 21:25:25 2B0D84E8 c dvbapi_qboxhd (0919&000000/2FED/B7:3777): found (2343 ms) by d_camd35 (of 1 avail 2)
2010/11/08 21:25:35 2B0D84E8 c dvbapi_qboxhd (0919&000000/2FED/B7:363D): found (2248 ms) by d_camd35 (of 1 avail 2)
2010/11/08 21:25:45 2B0D84E8 c dvbapi_qboxhd (0919&000000/2FED/B7:1572): found (2242 ms) by d_camd35 (of 1 avail 2)
2010/11/08 21:25:55 2B0D84E8 c dvbapi_qboxhd (0919&000000/2FED/B7:4B4A): found (2347 ms) by d_camd35 (of 1 avail 2)

If I disable LB, timing come back to normal value (about 200 mS)
With previous oscam version this don't happened.

Change History (1)

comment:1 by Deas, 10 years ago

Resolution: fixed
Status: newclosed

if i remember right this is fixed...

Note: See TracTickets for help on using tickets.