Opened 10 years ago

Closed 10 years ago

#1257 closed defect (fixed)

Cannot create pipe (errno=24) not good!

Reported by: rudi77 Owned by:
Priority: critical Component: Protocol - CCCam
Severity: high Keywords: pipe
Cc: Sensitive: no

Description

Revision

Oscam 3908 x64

Issue Description

Not good!
Im settings file-max=100000
Crash oscam!Im test two oscam server. One server runs well, another server crash always pipe.

This is log:
2010/11/17 1:11:07 6CFB1710 p cc_parse_msg out
2010/11/17 1:11:07 6CFB1710 p cc_recv_chk in
2010/11/17 1:11:07 6CFB1710 p cc_recv_chk out
2010/11/17 1:11:07 6CFB1710 p cc_parse_msg in 7
2010/11/17 1:11:07 6CFB1710 p cc_parse_msg out
2010/11/17 1:11:07 6CFB1710 p cc_recv_chk in
2010/11/17 1:11:07 6CFB1710 p cc_recv_chk out
2010/11/17 1:11:07 698B1E10 c cc_srv_init in
2010/11/17 1:11:07 698B1E10 c cc_srv_connect in
2010/11/17 1:11:07 7BDBA700 s Cannot create pipe (errno=24)
2010/11/17 1:11:07 7BDBA700 s exit with signal 1
2010/11/17 1:11:07 7BDBA700 s cardserver down

When the issue occurs

<Please fill in>

How the issue is reproducable

<Please fill in>

<Don't forget to ATTACH (not post here) a log file of oscam in debug mode (start oscam with -d255)!>

Change History (2)

comment:1 by Admin, 10 years ago

This error means that OSCam runs out of file descriptors. Could it be connected with the issue described here: http://www.streamboard.tv/wbb2/thread.php?threadid=30205 ?

comment:2 by Deas, 10 years ago

Resolution: fixed
Status: newclosed

no update => closed

Note: See TracTickets for help on using tickets.