Opened 10 years ago

Closed 10 years ago

#1328 closed defect (fixed)

Oscam exits on pcsc without inserted card

Reported by: docmarius Owned by:
Priority: major Component: Reader
Severity: medium Keywords: pcsc empty slot exit
Cc: Sensitive: no

Description

Revision

4025

Issue Description

Build x86_64 w. pcsc on Debian 5. Exits if pcsc card is enabled and no card inserted. Tested with an without waitforcards enabled, on first and third reader. Befor exit, card reader reports OFF in webif.
Same issue if card removed from reader and oscam already started.

When the issue occurs

Every startup. Issue occurs also occurs on svn-3996, doesn't occur on 1.00-stable-3665 which works properly
Issue does not occur on svn-3992 for dm/tuxbox with internal reader (found on PC with pcsc Omnikey 3121)

How the issue is reproducable

  1. Enable empty cardreader, restart oscam, wait about 10 sec, check with "ps -A"

2.Start oscam, check working, remove card, check with "ps -A"

Attachments (2)

oscam.log (5.6 KB ) - added by docmarius 10 years ago.
Debug log on failure
oscam.2.log (9.8 KB ) - added by docmarius 10 years ago.
Debug log svn-4105

Download all attachments as: .zip

Change History (10)

by docmarius, 10 years ago

Attachment: oscam.log added

Debug log on failure

comment:1 by docmarius, 10 years ago

I digged a little into this issue.

# The exiting happens only if caid is defined in oscam.server for the card and
# the card is pulled out or not inserted.
# If the caid line is commented out, everything works as expected.

LE: The exit is only postponed sometimes for a few minutes in this case and can survive a pullout/reinsert, but it still happens if oscam is accessed.
In this case it seems that exit occurs if a card access happens and the decoding capability is there (e.g via cccam line or card) but there is a reader without a card present.

Last edited 10 years ago by docmarius (previous) (diff)

comment:2 by Deas, 10 years ago

Resolution: fixed
Status: newclosed

by docmarius, 10 years ago

Attachment: oscam.2.log added

Debug log svn-4105

comment:3 by docmarius, 10 years ago

Problem is still here with svn-4093 and svn-4105.
I compiled with debug and added another log (oscam.2.log).

Please note that omnikey_2 is the reader without a card.
Exit occurs at about 5 seconds after startup.

Last edited 10 years ago by docmarius (previous) (diff)

comment:4 by docmarius, 10 years ago

Resolution: fixed
Status: closedreopened

comment:5 by lattjo, 10 years ago

Could you try to narrow the problem by using newcamd protocol instead of cccam? And perhaps check if it happens also with no client connected?

comment:6 by docmarius, 10 years ago

Hello,
Sorry for not replying earlier.
It seems svn_4153 now works properly.

Conditions:

  • OS: Debian Lenny x86_64
  • Oscam: svn 4153
  • build with "make linux-pcsc"

No libraries, drivers or compiler changed from earlier tests.

Combination tested (oscam restarted on every combination, also cards pulled out "live"):

  • 3 pcsc readers, 1 empty, no other "readers" active, 2 cccam clients using data from cardreader_1: OK.
  • 3 pcsc readers, 1 empty, 1 cccam "reader" on localhost, 2 cccam clients using data from cardreader_1: OK.
  • 3 pcsc readers, 1 empty, 2 cccam "reader", 1 localhost, 1 remote, 2 cccam clients using data from cardreader_1: OK.
  • 3 pcsc readers, 1 empty, 2 cccam "reader", 1 localhost, 1 remote, 2 cccam clients 1 using data from cardreader_1, 1 from remote cccam: OK.
  • 3 pcsc readers, 1 empty, 2 cccam "reader", 1 localhost, 1 remote, 1 cccam clients using data from cardreader_1, 1 oscam 4032 client from remote cccam: OK.
  • 3 pcsc readers, 3 empty, 2 cccam "reader", 1 localhost, 1 remote, 1 cccam clients trying ccid on cardreader 1, 1 oscam 4032 client trying ccid on cardreader 1: OK.
  • 3 pcsc readers, 3 empty, 2 cccam "reader", 1 localhost, 1 remote, 1 cccam clients using data from cardreader_1, 1 oscam 4032 client from remote cccam: OK.
  • 3 pcsc readers, 3 empty, 2 cccam "reader" , 1 off, 1 localhost, 1 cccam clients using data from cardreader_1, 1 oscam 4032 client from remote cccam: OK.
  • 3 pcsc readers, 3 empty, 2 cccam "reader" , 1 reconnected, 1 localhost, 1 cccam clients using data from cardreader_1, 1 oscam 4032 client from remote cccam: OK.
  • 3 pcsc readers, 2 empty, 1 only card contact, 2 cccam "reader" , 1 remote, 1 localhost, 1 cccam clients using data from cardreader_1, 1 oscam 4032 client from remote cccam: OK.
  • 3 pcsc readers, 2 empty, 2 cccam "reader" , 1 remote, 1 localhost, 1 cccam clients using data from cardreader_1, 1 oscam client from remote cccam: OK.
  • 3 pcsc readers, 2 empty, 2 cccam "reader" , 1 remote, 1 localhost, 1 cccam clients using data from cardreader_1, 1 oscam client from cardreader 1: OK.
  • 3 pcsc readers, 2 empty, 2 cccam "reader" , 1 remote, 1 localhost, 1 cccam clients using data from cardreader_1, 1 cccam client from cardreader 1: OK.

All these combinations reproduced the failure picture on earlier versions bot work now.

In my opinion this ticket can be closed as solved.

LE: can not confirm working on 4189 since pcsc readers with plugged cards state error, but oscam does not exit as before on empty reader (i think there is already another ticket on this issue...)

Last edited 10 years ago by docmarius (previous) (diff)

in reply to:  6 comment:7 by docmarius, 10 years ago

Confirm also working on svn-4195 using old reader-common.c file from svn-153 (no functional change except pcsc code enabled by HAVE_PCSC and close device function is left out in current file...).

I will close this ticket as fixed.

Last edited 10 years ago by docmarius (previous) (diff)

comment:8 by docmarius, 10 years ago

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.