Opened 12 years ago

Closed 12 years ago

#146 closed defect (fixed)

MSG_WAITALL' undeclared

Reported by: mcu_dreamer Owned by: cogsi
Priority: major Component:
Severity: medium Keywords:
Cc: Sensitive: no

Description

module-cccam.o

MSG_WAITALL' undeclared

#define MSG_WAITALL xxx iss missing

oscam/module-cccam.c: In function `cc_msg_recv':
oscam/module-cccam.c:413: error: `MSG_WAITALL' undeclared

Change History (4)

comment:1 by cogsi, 12 years ago

Owner: set to cogsi
Status: newassigned

MSG_WAITALL isn't declared in windowns. I'll fix this shortly.

comment:2 by cogsi, 12 years ago

Resolution: fixed
Status: assignedclosed

Fixed

comment:3 by crisman, 12 years ago

Resolution: fixed
Status: closedreopened

I tried today compiling with cygwin and the error about MSG_WAITALL come. So I think the problem is not fixed.

module-cccam.c:411: error: (Each undeclared identifier is reported only once
module-cccam.c:411: error: for each function it appears in.)
module-cccam.c: In function `cc_cli_connect':
module-cccam.c:842: error: `MSG_WAITALL' undeclared (first use in this function)

comment:4 by C.H.A.D.o, 12 years ago

Resolution: fixed
Status: reopenedclosed

Fixed in r761

Note: See TracTickets for help on using tickets.