Opened 10 years ago

Closed 10 years ago

#1613 closed defect (wontfix)

socket creation failed (erno=93) on kathrein 912 (with e2) with more than 1 servers to connect. sometimes also wenn i start oscam manualy over the softcam panel.

Reported by: gabberhead Owned by:
Priority: Please fill in Component: General
Severity: high Keywords:
Cc: Sensitive: no

Description

Revision

all

Issue Description

i always get a socket reation failed error whren im starting or restarting my kathrein 912 receiver. 99% it happends on my server which is connected via camd35 protokol. sometime it happend to one of my 2 which are connected via cccam protokoll. if oscam trys to connect to only one server it always connects without a problem. but if are 2 oder 3 to connect always one of them getting a socket creation failed. the same config i got on my kathrein 910 and there was NO problem like i have on the 912. and this not happen only to my 912, i got 4 of them with the same config and every one of them has the same problem. it seems in the forum i don´t get any tipps or comments about this thats because i opened a ticket!

When the issue occurs

every time when receiver is startet or restartet

How the issue is reproducable

2000/01/01 1:00:33 29FF84E8 h HTTP Server listening on port xxxxx
2000/01/01 1:00:33 297C52F8 s http thread started
2000/01/01 1:00:33 297C52F8 s creating thread for device 192.168.0.11
2000/01/01 1:00:33 2A7F84E8 p proxy thread started (thread=2A7F84E8, label=gabberhead, server=192.168.0.11)
2000/01/01 1:00:33 297C52F8 s creating thread for device xxxxxxxxxxxxxxx
2000/01/01 1:00:33 2AFF84E8 p proxy thread started (thread=2AFF84E8, label=xxxxxxx, server=xxxxxxxxxxxxxxx)
2000/01/01 1:00:33 297C52F8 s creating thread for device xxxxxxxxxxxxxxxxx
2000/01/01 1:00:33 2B7F84E8 p proxy thread started (thread=2B7F84E8, label=xxxxxx, server=xxxxxxxxxxx)
2000/01/01 1:00:33 297C52F8 s can't read from file /tmp/.oscam/stat
2000/01/01 1:00:33 297C52F8 s anti cascading disabled
2000/01/01 1:00:33 2BFF84E8 c plain dvbapi-client granted (gabberhead, au=gabberhead)
2000/01/01 1:00:33 2BFF84E8 c dvbapi: 54 entries read from oscam.dvbapi
2000/01/01 1:00:34 2AFF84E8 p proxy reader: xxxx(xxxxxxxxxx:xxxxxx) cccam v2.1.4 build 3191, maxhop: 2
2000/01/01 1:00:34 2AFF84E8 p connecting to xxxxxxxxxxxxxxxxxxx
2000/01/01 1:00:34 2A7F84E8 p Socket creation failed (errno=93) 2000/01/01 1:00:34 2A7F84E8 p exit with signal 1 2000/01/01 1:00:34 2A7F84E8 p thread 2A7F84E8 ended!
2000/01/01 1:00:34 2B7F84E8 p proxy reader: xxxxx (xxxxxxxxxxxx:xxxxx) cccam v2.1.4 build 3191, maxhop: 2
2000/01/01 1:00:34 2B7F84E8 p connecting to xxxxxxxxxxxxxxxxx
2000/01/01 1:00:34 2AFF84E8 p xxxxxxxxxxxx: resolved ip=xxxxxxxxxx
2000/01/01 1:00:34 2B7F84E8 p xxxxxxxxxxxxxxx: resolved ip=xxxxxxxxxxxxx
2000/01/01 1:00:34 2AFF84E8 p cccam(r) xxxxxx: sending own version: 2.1.4, build: 3191
2000/01/01 1:00:34 2AFF84E8 p cccam(r) xxxxxx: MSG_SRV_DATA (payload=72, hex=4cool
2000/01/01 1:00:34 2AFF84E8 p cccam(r) xxxxxx: srv 5E04305BE7754D71 running v2.0.11 (2892)
2000/01/01 1:00:35 2B7F84E8 p cccam(r) xxxxxx: sending own version: 2.1.4, build: 3191
2000/01/01 1:00:35 2B7F84E8 p cccam(r) xxxxxx: MSG_SRV_DATA (payload=72, hex=4cool
2000/01/01 1:00:35 2B7F84E8 p cccam(r) xxxxxx: srv BE04CAE0246CEB06 running v2.0.11 (2892)

Change History (6)

comment:1 by gabberhead, 10 years ago

one thing. when i am starting or restarting oscam after the receiver is running via he softcam panel it works every time. it always connects to alle the servers without problem.

comment:2 by Deas, 10 years ago

Resolution: invalid
Status: newclosed

you don´t start oscam with a 25 second delay. the network from the ufs912 takes that long to start. http://www.streamboard.tv/wbb2/thread.php?threadid=30607

comment:3 by gabberhead, 10 years ago

Resolution: invalid
Status: closedreopened
Summary: socket creation failed (erno=93) on kathrein 912 with more than 1 servers to connectsocket creation failed (erno=93) on kathrein 912 (with e2) with more than 1 servers to connect

i am running e2 not the original software.

comment:4 by Deas, 10 years ago

and that means your network is ready immediately after you switch on the box??? this can only be a problem of your hardware as you said when the box is running and you make a restart or start oscam it is working. with my ufs910 it was also not necessary to add such a high delay. but the 912 needs that.

comment:5 by gabberhead, 10 years ago

Severity: mediumhigh
Summary: socket creation failed (erno=93) on kathrein 912 (with e2) with more than 1 servers to connectsocket creation failed (erno=93) on kathrein 912 (with e2) with more than 1 servers to connect. sometimes also wenn i start oscam manualy over the softcam panel.

comment:6 by Admin, 10 years ago

Resolution: wontfix
Status: reopenedclosed

This is not an OSCam fault. No network available = No OSCam start. This won't be fixed.

According to your log, you also have another issue: You should make sure that the time is correct before starting OSCam.

If you need any further discussion on this topic, use the forum.

Note: See TracTickets for help on using tickets.