Opened 11 years ago

Closed 11 years ago

#1962 closed defect (wontfix)

CCCam wrong hops count on clients without services

Reported by: superg1972 Owned by: schlocke
Priority: major Component: Protocol - CCCam
Severity: medium Keywords:
Cc: Sensitive: no

Description

Revision

5461 and previous

Issue Description

If you don't put services on the card reader, when a channel is not in your bouqet and it is taken from a proxy reader the Hop counter that appear on a CCCam client connected to Oscam is wrong.
If you put the services configuration it works fine.
The problem without services is when on the card you have a "not found" and the channel is taken from a proxy on the CCCam client appears Hop 1 isntead of Hop2

Example
CCCam Client connected to Oscam
Oscam as Server with Proxy 1and a local card and no services set.

CCam Client ask to Oscam a SRVID on the CAID of local card. SRVID is not present on the card and so you get "not found". The SRVIDis found on the proxy. In this case the Hop count that appear on the client is 1 instead of 2.

If you put the service the hop count is correct.

When the issue occurs

Always without services configured on the local card reader

How the issue is reproducable

follow the example

Change History (2)

comment:1 by pooyair, 11 years ago

Owner: set to schlocke

comment:2 by schlocke, 11 years ago

Resolution: wontfix
Status: newclosed

Oscam is a ECM router, not a card router. By default, ECMs are routed to the reader that can decode it. Activate "forward origin card" to avoid this. But beware, that cache and loadbalancer is deactivated in this case.

Note: See TracTickets for help on using tickets.