Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#21 closed enhancement (fixed)

oscam.cert to oscam.server

Reported by: landlord Owned by: nightmann
Priority: trivial Component: Reader
Severity: low Keywords:
Cc: Sensitive: no

Description

Issuer Public Keys (IPK) should be defined in oscam.server reader section.

Change History (8)

comment:1 by nightmann, 12 years ago

Owner: set to nightmann
Priority: majortrivial
Severity: mediumlow

comment:2 by nightmann, 12 years ago

Status: newassigned

I would prefer that we go the other way.
All Keys like ipk, boxkey and nagra RSA Keys go to one file.
So we can build one file like this
foo: {caid, boxkey, rsa}

The advantage is that is not reader depend.
User can insert card in every reader and dont must change the keys in oscam.server.

In my opinion vars to oscam.server reader should be only reader related vars like mhz and type all.

What did you and other people think?

comment:3 by Deas, 12 years ago

Component: General
Resolution: fixed
Sensitive: unset
Status: assignedclosed

no update sincd 3 months...

comment:4 by landlord, 12 years ago

Resolution: fixed
Status: closedreopened

comment:5 by landlord, 12 years ago

Component: GeneralReader

comment:6 by pooyair, 11 years ago

Resolution: fixed
Status: reopenedclosed

oldest ticket without any update since 12 month ago

i thing this by design and nobody in this 12 months update it

http://www.streamboard.tv/svn/oscam/trunk/Distribution/doc/txt/oscam.cert.txt

Last edited 11 years ago by pooyair (previous) (diff)

comment:7 by Admin, 11 years ago

Actually, he wanted to move oscam.cert into oscam.server so from this point it's not fixed. However, the question is if it really makes sense or not. I'm also not sure what we should do or not here. When I see how many questions the quite trivial tiger_rsakey change brought up I would say to let it stay like it is...

comment:8 by pooyair, 11 years ago

you are right admin
also i might change it to won't fix... (though this ticket might be fix in future). but if no devs hadn't interest for this change of design for 12 months... i think this new features could be discuss (ie cause nightmann like in other form....) in forum or if one devs interested to this new features (use oscam.cert in oscam.server) he will commit it with or without this ticket cause i think most of the devs do change by their own special interest or usage isn't it? ie i saw 2 tickets for adding yes card support (with logs) but no devs commit it since 6 months ago because no devs hasn't this card or interest on that but we let them open cause there are some useful log might be helpful in future but in this ticket even not clear why this change might be happened?

Regards

Note: See TracTickets for help on using tickets.