Opened 12 years ago

Closed 11 years ago

#217 closed defect (fixed)

Oscam couldnt handle some S02 Cards over Smargo (too much TIERS?)

Reported by: einmalacht Owned by:
Priority: major Component: Reader
Severity: medium Keywords:
Cc: zepter-salchendorf@… Sensitive: no

Description

debianserver:~# /var/bin/oscam64bit -d63
2009/12/14 17:03:15 2704 s >> OSCam << cardserver started version 0.99.4svn, build #820 (x86_64-pc-linux)
2009/12/14 17:03:15 2704 s auth size=8856
2009/12/14 17:03:15 2704 s services reloaded: 0 services freed, 1 services loaded
2009/12/14 17:03:15 2704 s userdb reloaded: 0 accounts freed, 1 accounts loaded
2009/12/14 17:03:15 2704 s signal handling initialized (type=sysv)
2009/12/14 17:03:15 2704 s 2276 service-id's loaded
2009/12/14 17:03:15 2704 s monitor: disabled
2009/12/14 17:03:15 2704 s camd 3.3x: disabled
2009/12/14 17:03:15 2704 s camd 3.5x: disabled
2009/12/14 17:03:15 2704 s cs378x: disabled
2009/12/14 17:03:15 2704 s newcamd: initialized (fd=5, port=50003, crypted)
2009/12/14 17:03:15 2704 s CAID: 1702
2009/12/14 17:03:15 2704 s provid #0: 000000
2009/12/14 17:03:15 2704 s radegast: disabled
2009/12/14 17:03:15 2704 s resolver thread started
2009/12/14 17:03:15 2704 s logger started (pid=2706)
2009/12/14 17:03:15 2706 l starting client 0 with ip 127.0.0.1
2009/12/14 17:03:15 2704 s resolver started (pid=2707, delay=30 sec)
2009/12/14 17:03:15 2707 n starting client 0 with ip 127.0.0.1
2009/12/14 17:03:15 2704 s reader started (pid=2708, device=/dev/ttyUSB0, detect=cd, mhz=357, cardmhz=357)
2009/12/14 17:03:15 2704 s Waiting for local card init ....
2009/12/14 17:03:15 2708 r02 starting client 0 with ip 127.0.0.1
2009/12/14 17:03:16 2708 r02 standard baudrate: cardmhz=357 mhz=357 -> effective baudrate 1200
2009/12/14 17:03:18 2704 s Init for all local cards done !
2009/12/14 17:03:18 2704 s anti cascading disabled
2009/12/14 17:03:18 2708 r02 standard baudrate: cardmhz=357 mhz=357 -> effective baudrate 9600
2009/12/14 17:03:19 2708 r02 ct_init on /dev/ttyUSB0: 0
2009/12/14 17:03:20 2708 r02 card detected
2009/12/14 17:03:24 2708 r02 ATR reports smartcard supports 1 protocols:
2009/12/14 17:03:24 2708 r02 Protocol 1: TA1=21 TD1=0E (T14)
2009/12/14 17:03:24 2708 r02 No PTS, selected protocol 1: T14, F=372, D=1.000000, N=0

2009/12/14 17:03:24 2708 r02 ATR: 3B 9F 21 0E 49 52 44 45 54 4F 20 41 43 53 03 84 55 FF 80 6D
2009/12/14 17:03:25 2708 r02 [nagra-reader] detect Irdeto tunneled nagra card
2009/12/14 17:03:25 2708 r02 write to cardreader skyde:
2009/12/14 17:03:25 2708 r02 02 02 03 00 00
2009/12/14 17:03:25 2708 r02 answer from cardreader skyde:
2009/12/14 17:03:25 2708 r02 03 84 00 00 00 17 02 00 00 00 00 00 00 47 45 52
2009/12/14 17:03:25 00 00
2009/12/14 17:03:25 2708 r02 type: irdeto, caid: 1702, acs: 3.84
2009/12/14 17:03:25 2708 r02 write to cardreader skyde:
2009/12/14 17:03:25 2708 r02 02 00 03 00 00
2009/12/14 17:03:25 2708 r02 answer from cardreader skyde:
2009/12/14 17:03:25 2708 r02 30 32 37 37 31 39 33 33 35 36 00 00 00 00 00 00
2009/12/14 17:03:25 00 00 00 00 00 00
2009/12/14 17:03:25 2708 r02 write to cardreader skyde:
2009/12/14 17:03:25 2708 r02 02 01 00 00 00
2009/12/14 17:03:25 2708 r02 answer from cardreader skyde:
2009/12/14 17:03:25 2708 r02 00 17 00 00 02 00 17 00 00 03 04 80 85 A2 8C 1A
2009/12/14 17:03:25 00 00
2009/12/14 17:03:25 2708 r02 ascii serial: 0XXXXXXXX, hex serial: XXXXXX, hex base: 1A
2009/12/14 17:03:25 2708 r02 write to cardreader skyde:
2009/12/14 17:03:25 2708 r02 02 0E 02 00 00
2009/12/14 17:03:25 2708 r02 answer from cardreader skyde:
2009/12/14 17:03:25 2708 r02 A9 6D 73 97 9E FC 9B 8E 5B 8C FA B2 0C B2 57 0F
2009/12/14 17:03:25 B2 F7 29 4E A2 CB BD 5B 52 74 B1 2A B7 C5 D9 62
2009/12/14 17:03:25 6D 37 6D 9D A3 E9 61 BB 1B 2B 56 B7 86 0C E6 B1
2009/12/14 17:03:25 07 6F E0 F8 8A D3 05 83 F6 53 0E D2 72 D5 C1 50
2009/12/14 17:03:25 00 00
2009/12/14 17:03:25 2708 r02 write to cardreader skyde:
2009/12/14 17:03:25 2708 r02 02 0E 03 00 00
2009/12/14 17:03:26 2708 r02 answer from cardreader skyde:
2009/12/14 17:03:26 2708 r02 B6 DE A8 CE 86 1C 42 72 A8 16 4B F9 CE 33 B5 43
2009/12/14 17:03:26 D0 50 E6 A7 F1 CB 55 25 97 13 EE 62 98 E7 17 50
2009/12/14 17:03:26 EB 3B 59 10 0A B6 2E 93 61 71 3C E6 E2 2C 1E 7D
2009/12/14 17:03:26 BD 6A 49 BB 04 5B DF 2F B7 A7 93 E0 3D 40 4E D1
2009/12/14 17:03:26 00 00
2009/12/14 17:03:26 2708 r02 set camkey for type=1
2009/12/14 17:03:26 2708 r02 write to cardreader skyde:
2009/12/14 17:03:26 2708 r02 02 09 03 00 40 18 D7 55 14 C0 83 F1 38 39 6F F2
2009/12/14 17:03:26 EC 4F E3 F1 85 01 46 06 CE 7D 08 2C 74 46 8F 72
2009/12/14 17:03:26 C4 EA D7 9C E0 E1 FF 58 E7 70 0C 92 45 26 18 4F
2009/12/14 17:03:26 A0 E2 F5 9E 46 6F AE 95 35 B0 49 B2 0E A4 1F 8E
2009/12/14 17:03:26 47 D0 24 11 D0
2009/12/14 17:03:30 2708 r02 answer from cardreader skyde:
2009/12/14 17:03:30 2708 r02 write to cardreader skyde:
2009/12/14 17:03:30 2708 r02 D0 74 01 80 01
2009/12/14 17:03:30 2708 r02 answer from cardreader skyde:
2009/12/14 17:03:30 2708 r02 6F 00

2009/12/14 17:03:30 2708 r02 failed to read 7401 cmd length (00 a8)

2009/12/14 17:03:30 2708 r02 card system not supported
2009/12/14 17:03:30 2708 r02 card initializing error

Attachments (3)

oscam-S02-smargo-working.log.gz (4.6 KB ) - added by szepter 12 years ago.
oscam-S02-smargo-failing.log.gz (3.7 KB ) - added by szepter 12 years ago.
oscam-S02-mouse-working.log (63.6 KB ) - added by szepter 12 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 by einmalacht, 12 years ago

The problem is reading the Camkey but i dont know why only in Smargo!

comment:2 by nightmann, 12 years ago

Resolution: invalid
Status: newclosed

please try a more recent version.

comment:3 by szepter, 12 years ago

Cc: zepter-salchendorf@… added
Resolution: invalid
Status: closedreopened
version: 1.0

I am still experiencing some kind of this problem. Maybe my problem is related to this?
See: http://www.streamboard.tv/wbb2/thread.php?threadid=28060

by szepter, 12 years ago

by szepter, 12 years ago

comment:4 by szepter, 12 years ago

oscam-S02-smargo-working.log.gz shows a working S02 card in Smargo.
oscam-S02-smargo-failing.log.gz shows the failing S02 card in Smargo.
Smargos have been swapped, so we could eliminate the circumstance of a non-working Smargo reader.
oscam-S02-mouse-working.log.gz shows the S02 card, which fails in Smargo, working in a Smartmouse reader.

by szepter, 12 years ago

Attachment: oscam-S02-mouse-working.log added

comment:5 by szepter, 12 years ago

version: 1.0

comment:7 by szepter, 12 years ago

I have the card available for testing now and applied this small "fix" from below. It seems this works at least for this card.

Index: csctapi/protocol_t0.c
===================================================================
--- csctapi/protocol_t0.c       (Revision 2007)
+++ csctapi/protocol_t0.c       (Arbeitskopie)
@@ -485,7 +485,7 @@
                return ERROR;
        }

-       if (reader->typ <= R_MOUSE) {
+       if (FALSE) { //reader->typ <= R_MOUSE) {
                call (ICC_Async_Transmit (reader, 1, &b1));                                             //send 0x01 byte
                call (ICC_Async_Transmit (reader, cmd_len, cmd_raw));   //send apdu
                call (ICC_Async_Transmit (reader, 1, &ixor));                                   //Send xor byte

It has been tested in a Smargo with 6.00 MHz fixed as well as 8.00 MHz fixed, T = 1 and Kernel = Normal. I have also tested with and without the "CardMHz = 600" and "MHz = 600" settings... all of them work.

comment:8 by alno, 12 years ago

Component: Reader
Sensitive: unset

comment:9 by Deas, 11 years ago

Resolution: fixed
Status: reopenedclosed

please test with a more recent version and reopen if problem still exist.

Note: See TracTickets for help on using tickets.