Opened 9 years ago

Closed 8 years ago

#2621 closed defect (fixed)

Fastmode (reset) Sky IT with easymouse2 is broken

Reported by: BigGyros Owned by:
Priority: major Component: Reader
Severity: medium Keywords: fastmode reset
Cc: Sensitive: no

Description

Revision

7149

Issue Description

Sky IT cards are able to run in fastmode 15. The problem here ist that the card won't be recognized after in7e injection. Only an oscam restart will init the card correct.

When the issue occurs

after every new card reset

How the issue is reproducable

put card into original stb and than into oscam with easymouse2

Attachments (5)

fastmodeerroreasymouse2.zip (5.2 KB ) - added by BigGyros 9 years ago.
skyitinitok15.zip (2.4 KB ) - added by BigGyros 9 years ago.
oscamskyitinitokandnotokdebug.log (110.9 KB ) - added by BigGyros 9 years ago.
init ok and not ok in debug mode
oscamskyitfastmode15errorinit.log.txt (180.6 KB ) - added by BigGyros 9 years ago.
new debug log with #7951
oscamskyitfastmode15errorinit.log.2.txt (179.9 KB ) - added by BigGyros 9 years ago.
debug log 7996

Download all attachments as: .zip

Change History (11)

by BigGyros, 9 years ago

Attachment: fastmodeerroreasymouse2.zip added

by BigGyros, 9 years ago

Attachment: skyitinitok15.zip added

by BigGyros, 9 years ago

init ok and not ok in debug mode

comment:1 by Deas, 9 years ago

Resolution: invalid
Status: newclosed

please try with latest version if problem still exists...

comment:2 by BigGyros, 9 years ago

Resolution: invalid
Status: closedreopened

tested latest version and problem is still the same

this issue belongs only to the easymouse2 readers

comment:3 by Deas, 9 years ago

and where is the DEBUG LOG?!? i don´t think that a 4 month old log can help...

by BigGyros, 9 years ago

new debug log with #7951

by BigGyros, 9 years ago

debug log 7996

comment:4 by malakudi, 8 years ago

The problem happens from http://www.streamboard.tv/oscam/changeset/6098 . Fast reset never worked in easymouse2 and similar phoenix readers. It only worked before 6098, when there was no fast reset. After restarting OSCAM, card already has changed ATR, and that's why it works.

I will try to fix fast reset for phoenix.

edit: By "fast reset" I mean the change applied in 6098, not operating fast with ins7e11 = 15 for example.

Last edited 8 years ago by malakudi (previous) (diff)

comment:5 by malakudi, 8 years ago

Reverting the fast_reset code change in ifd_phoenix.c resolves the issue.

--- ifd_phoenix.c.orig  2013-02-27 03:30:35.000000000 +0200
+++ ifd_phoenix.c       2013-02-27 03:30:58.000000000 +0200
@@ -106,12 +106,7 @@
                unsigned char buf[ATR_MAX_SIZE];
                int32_t parity[3] = {PARITY_EVEN, PARITY_ODD, PARITY_NONE};

-               if ( ! reader->ins7e11_fast_reset ) {
-                       call (IO_Serial_SetBaudrate(reader, DEFAULT_BAUDRATE));
-               }
-               else {
-                       rdr_log(reader, "Doing fast reset");
-               }
+                call (IO_Serial_SetBaudrate(reader, DEFAULT_BAUDRATE));

                for(i=0; i<3; i++) {
                        if (reader->crdr.flush) IO_Serial_Flush(reader);

It actually sets baudrate again to 9600 before reading ATR. Since I don't really understand why it doesn't work when not setting baudrate again to 9600, I can't fix it completely. However, reset with setting baudrate to 9600 for reading ATR is still fast enough, and ins7e11 works fine (no need to restart oscam).

I currently don't have other phoenix reader (smargo?) to test.

comment:6 by lattjo, 8 years ago

Resolution: fixed
Status: reopenedclosed

Fixed in r8440

Note: See TracTickets for help on using tickets.