Opened 9 years ago

Closed 9 years ago

#2653 closed defect (fixed)

Big Problems with DVBAPI since long time

Reported by: hk2k2 Owned by:
Priority: critical Component: DVBApi
Severity: Please fill in Keywords:
Cc: Sensitive: no

Description

Revision

??7000<till now..

Issue Description

"Found" appears in Log, but no decode

When the issue occurs

if a caid can´t be decoded..

How the issue is reproducable

Block currently used CAID on server, if client has no other proxy, problem occurs.

With Request Mode 1: API won´t try anything, just stop and says "cant decode channel"

2012/07/25 18:19:08 76E012D8 c dvbapi: Start descrambling PID #2 (CAID: 09C4) 1
2012/07/25 18:19:08 76E012D8 c api (09C4&000000/0000/0083/90:1892): found (196 ms) by 4-asus-rtn66u (P/1/1/2) - Sky Cinema HD
2012/07/25 18:19:15 76E012D8 c api (09C4&000000/0000/0083/90:F39F): found (193 ms) by 4-asus-rtn66u (P/1/1/2) - Sky Cinema HD
2012/07/25 18:19:22 76E012D8 c api (09C4&000000/0000/0083/90:8F77): found (195 ms) by 4-asus-rtn66u (P/1/1/2) - Sky Cinema HD
2012/07/25 18:19:29 76E012D8 c api (09C4&000000/0000/0083/90:2D77): found (194 ms) by 4-asus-rtn66u (P/2/2/2) - Sky Cinema HD
2012/07/25 18:19:36 76E012D8 c api (09C4&000000/0000/0083/90:7954): found (202 ms) by 4-asus-rtn66u (P/2/2/2) - Sky Cinema HD
2012/07/25 18:19:43 76E012D8 c api (09C4&000000/0000/0083/90:4565): found (196 ms) by 4-asus-rtn66u (P/2/2/2) - Sky Cinema HD
2012/07/25 18:19:50 7710E430 p 4-asus-rtn66u CMD08 (00 - 0) stop request by server (ok)
2012/07/25 18:19:51 76E012D8 c api (09C4&000000/0000/0083/90:ED38): found (700 ms) by 5-dm800se (F/2/2/2) - Sky Cinema HD
2012/07/25 18:19:57 7710E430 p 4-asus-rtn66u CMD08 (00 - 0) stop request by server (ok)
2012/07/25 18:19:58 76E012D8 c api (09C4&000000/0000/0083/90:0350): found (462 ms) by 5-dm800se (F/2/2/2) - Sky Cinema HD
2012/07/25 18:20:04 7710E430 p 4-asus-rtn66u CMD08 (00 - 0) stop request by server (ok)
2012/07/25 18:20:08 76E012D8 c dvbapi: can't decode channel
2012/07/25 18:20:08 76E012D8 c api (09C4&000000/0000/0083/90:DB2B): not found (3970 ms) by 5-dm800se (F/2/2/2) - Sky Cinema HD

i blocked 09C4 on BOTH proxies, request mode 1. and then oscam stops!

with request mode 0:

i watched 1702 caid, then blocked it! after some NOT FOUNDS oscam switches CAID, BUT. image is dark! no decode
only rezap helps.

2012/07/25 18:23:27 77010D58 c dvbapi: Start descrambling PID #0 (CAID: 1702) 1
2012/07/25 18:23:27 77010D58 c api (1702&000000/0000/000B/93:8855): found (1169 ms) by 4-asus-rtn66u - Sky Cinema +1
2012/07/25 18:23:36 77010D58 c api (1702&000000/0000/000B/93:61F6): found (1726 ms) by 4-asus-rtn66u - Sky Cinema +1
2012/07/25 18:23:46 77010D58 c api (1702&000000/0000/000B/93:A057): found (1070 ms) by 4-asus-rtn66u - Sky Cinema +1
2012/07/25 18:23:55 77005408 p 4-asus-rtn66u CMD08 (00 - 0) stop request by server (ok)
2012/07/25 18:23:55 77010D58 c api (1702&000000/0000/000B/93:621E): not found (2 ms) by 4-asus-rtn66u - Sky Cinema +1
2012/07/25 18:24:05 77005408 p 4-asus-rtn66u CMD08 (00 - 0) stop request by server (ok)
2012/07/25 18:24:05 77010D58 c api (1702&000000/0000/000B/93:10EA): not found (3 ms) by 4-asus-rtn66u - Sky Cinema +1
2012/07/25 18:24:05 77005408 p 4-asus-rtn66u CMD08 (00 - 0) stop request by server (ok)
2012/07/25 18:24:15 77005408 p 4-asus-rtn66u CMD08 (00 - 0) stop request by server (ok)
2012/07/25 18:24:15 77010D58 c api (1702&000000/0000/000B/93:C4A3): not found (2 ms) by 4-asus-rtn66u - Sky Cinema +1
2012/07/25 18:24:25 77005408 p 4-asus-rtn66u CMD08 (00 - 0) stop request by server (ok)
2012/07/25 18:24:25 77010D58 c api (1702&000000/0000/000B/93:0150): not found (2 ms) by 4-asus-rtn66u - Sky Cinema +1
2012/07/25 18:24:26 77010D58 c dvbapi: Start descrambling PID #1 (CAID: 1722) 1
2012/07/25 18:24:26 77010D58 c api (1722&000000/0000/000B/93:33BF): found (1621 ms) by 4-asus-rtn66u - 1722:000B unknown
2012/07/25 18:24:40 77010D58 c api (1722&000000/0000/000B/93:FEBC): timeout (5000 ms) - 1722:000B unknown
2012/07/25 18:24:45 77005408 p 4-asus-rtn66u CMD08 (00 - 0) stop request by server (ok)
2012/07/25 18:24:45 77010D58 c api (1722&000000/0000/000B/93:40E1): not found (3 ms) by 4-asus-rtn66u - 1722:000B unknown
2012/07/25 18:24:58 77010D58 c api (1722&000000/0000/000B/93:F032): found (2957 ms) by 4-asus-rtn66u - 1722:000B unknown
2012/07/25 18:25:10 77010D58 c api (1722&000000/0000/000B/93:F7CC): timeout (5001 ms) - 1722:000B unknown
2012/07/25 18:25:15 77005408 p 4-asus-rtn66u CMD08 (00 - 0) stop request by server (ok)
2012/07/25 18:25:15 77010D58 c api (1722&000000/0000/000B/93:30D0): not found (2 ms) by 4-asus-rtn66u - 1722:000B unknown
2012/07/25 18:25:16 77010D58 c dvbapi: Start descrambling PID #2 (CAID: 1833) 1
2012/07/25 18:25:16 77010D58 c api (1833&000000/0000/000B/89:A20A): found (1051 ms) by 4-asus-rtn66u - Sky Cinema +1
2012/07/25 18:25:26 77010D58 c api (1833&000000/0000/000B/89:7FDF): found (1179 ms) by 4-asus-rtn66u - Sky Cinema +1
2012/07/25 18:25:36 77010D58 c api (1833&000000/0000/000B/89:58CD): found (1074 ms) by 4-asus-rtn66u - Sky Cinema +1
2012/07/25 18:25:45 77010D58 c api (1833&000000/0000/000B/89:6D91): found (919 ms) by 4-asus-rtn66u - Sky Cinema +1
2012/07/25 18:25:55 77010D58 c api (1833&000000/0000/000B/89:5A79): found (857 ms) by 4-asus-rtn66u - Sky Cinema +1
2012/07/25 18:26:06 77010D58 c api (1833&000000/0000/000B/89:E311): found (1066 ms) by 4-asus-rtn66u - Sky Cinema +1

I´m using LB mode 1, and auto betatunnel

last tried oscam is 7204.

please check this issue.
thanks

Change History (7)

comment:1 by spock, 9 years ago

currently on #7206.

I see the same thing a lot (guessing thanks to a not too stable internet connection)..

Any configuration setting make no difference really. lb_mode=0,1,2,3,10.. it's all the same. Request modes seems to make some difference to how/when the problems occur, but no matter what, they will sooner or later show up.

decoding just stops, and log usually shows "can't decode channel", and after/before that I see a timeout, reject or such. I've really tried every possible way to configure oscam too, but nothing helps. Issue have been around for months or more. Configuring sids in oscam.services do help to some extent (oscam seems to be less likely to give up when oscam.services is defined and used).

I've made 2 similar tickets but they seem to be more or less ignored (it is summer vacations time though so maybe devs are away).

Sticking with 1.10 stable seems to be the best route at the moment..

http://www.streamboard.tv:8001/ticket/2615
http://www.streamboard.tv:8001/ticket/2627

Last edited 9 years ago by spock (previous) (diff)

comment:2 by hk2k2, 9 years ago

i forgot: i use Dreambox 8000, Mipsel tuxbox.

br

comment:3 by hk2k2, 9 years ago

an idea for request mode 0 problem:

if oscam does:
dvbapi: Start descrambling PID #2 (CAID: xxxx) 1,
is it possible, that oscam re-read all PID´s like it does if i first zap to the channel ?
maybe then the channel works?

br

comment:4 by hk2k2, 9 years ago

i checked out some more:

logging with level 128 , i figured out something:

normal watching a SKY channel, CAID 1702:

2012/07/28 20:31:01 77520BC0 c dvbapi: dvbapi request cw for 1702&000000/0000/000E/93:0000
2012/07/28 20:31:02 77520BC0 c dvbapi: write cw0 index: 0 (ca3)
2012/07/28 20:31:02 77520BC0 c api (1702&000000/0000/000E/93:3ED1): found (881 ms) by 4-asus-rtn66u - Discovery Channel

then i blocked CAID 1702 on server, and wait until oscam tries an other caid, in my case, 1722, BUT:

2012/07/28 20:31:43 77520BC0 c dvbapi: dvbapi request cw for 1722&000000/0000/000E/93:0000
2012/07/28 20:31:44 77520BC0 c dvbapi: write cw0 index: 1 (ca3)
2012/07/28 20:31:44 77520BC0 c api (1722&000000/0000/000E/93:F83D): found (653 ms) by 4-asus-rtn66u - 1722:000E unknown

i got a fOUND, but no picture! i see that INDEX is 1 now, instead of 0 before.

then i rezapped , and now got this:

2012/07/28 20:31:58 77520BC0 c dvbapi: dvbapi request cw for 1722&000000/0000/000E/93:0000
2012/07/28 20:31:59 77520BC0 c dvbapi: write cw0 index: 0 (ca3)
2012/07/28 20:31:59 77520BC0 c api (1722&000000/0000/000E/93:2C24): found (632 ms) by 4-asus-rtn66u - 1722:000E unknown

caid 1722 is working, i got a picture, and index is 0!

is this important ??

i used request mode 0 for this tests.

br

comment:5 by Deas, 9 years ago

Resolution: fixed
Status: newclosed

should be fixed with r8017 and newer with decodeforever = 1

comment:6 by hk2k2, 9 years ago

Resolution: fixed
Status: closedreopened

Problem occurs again! seems to be fixed in ~8100, but last oscams have the same problem again,

theparasol fixed something, but this broke other boxtype api ..

i refer to this thread:
http://www.streamboard.tv/wbb2/thread.php?threadid=36282&page=11

br

comment:7 by Deas, 9 years ago

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.