Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2657 closed enhancement (invalid)

Single WebIF template doesn't read site.css as "embedded" css, same with oscam.js

Reported by: Znuff Owned by: alno
Priority: trivial Component: Webinterface
Severity: low Keywords: webif, template
Cc: Sensitive: no

Description

Revision

7070+

Issue Description

When using a custom tpl location, like /usr/local/etc/mytemplate, the /usr/local/etc/mytemplate/site.css file *should* be treated as "embedded", or, rather "default css". Same goes for ./oscam.js

This works fine when using the template sets feature introduced in [7070], /usr/local/etc/templates/mytemplate/site.css is treated as "embedded" when accesing the WebIF trough a url like http://myhost:port/mytemplate/

When the issue occurs

Custom http_tpl location

How the issue is reproducable

Point WebIF's http_tpl to a directory (eg: /usr/local/etc/tpl), create a site.css inside /usr/local/etc/tpl and/or an oscam.js.

Files won't be read as "default", you'd have to point the WebIF manually to the location of those files as if they are "external" files.

(log file is not relevant)

Change History (4)

comment:1 by Admin, 12 years ago

Type: defectenhancement

This is not a defect but a described behaviour. The only point I can see is to remove these two parameters (httpjscript and httpcss) alltogether. However, this makes switching between styles (different externals or the internal) more difficult as you can't do it from within OSCam webinterface anymore. Please discuss this in the forum first.

comment:2 by Znuff, 12 years ago

Then how about implementing a way to list the .css files inside the http_tpl directory, not just the ones in /usr/local/etc (or whatever the default config directory happens to be)? Or adding a simple select option if http_tpl is enabled and contains a file called site.css to show up as "custom template css" (or something less confusing, I guess)?

(Sorry I didn't follow-up on the forum, but I think it's an overkill to create a thread just for this last question)

Last edited 12 years ago by Znuff (previous) (diff)

comment:3 by Deas, 12 years ago

Resolution: invalid
Status: newclosed

this is a ticket system, the forum for discussions. as this is no defect it must be discussed first in the forum as not all user using oscam are reading each trac ticket. and we won´t change this behaviour just because one person wants it. this is no overkill, just a normal way to discuss things.

comment:4 by Admin, 12 years ago

I implemented your last suggestion with listing the file. Hope that's ok now, if a further change in functionality is needed, please discuss this in the forum like said.

Note: See TracTickets for help on using tickets.