Opened 12 years ago

Closed 12 years ago

Last modified 7 years ago

#2659 closed defect (invalid)

Oscam doesn't retry to get ECM when gets timeout

Reported by: ivoant Owned by:
Priority: major Component: DVBApi
Severity: medium Keywords:
Cc: Sensitive: no

Description

Revision

7218

Issue Description

When the ECM gets timeout, OSCAM says that cannot decode the channel and then nothing (it doesn't retry to receive ECM)

When the issue occurs

When i updated from ymodv18-t33 to svn7212 (with ymod it retries always when it gives timeout, rejected reader or not found)

How the issue is reproducable

When i ReZAPP the service it works for 1-2 minutes (my line isn't good) and then it gives "timeout"

Attachments (1)

oscam.log (26.7 KB ) - added by ivoant 12 years ago.
OScam LOG

Download all attachments as: .zip

Change History (4)

by ivoant, 12 years ago

Attachment: oscam.log added

OScam LOG

comment:1 by Znuff, 12 years ago

Is Loadbalancer enabled? Can't tell from the log.

comment:2 by Deas, 12 years ago

Resolution: invalid
Status: newclosed

if you have just one reader (on hop 3!) - what do you expect?

http://www.streamboard.tv/wiki/OSCam/en/Config/oscam.conf#lb_reopen_mode

comment:3 by narsilva, 7 years ago

if lb_reopen_mode did change this behavior(?)... it seems not an option anymore...

sorry to persist on this... but... no chance we can at least get a config option (ok not default) to make it retry after timeout? in some cases it would be useful due to network issues, bad server, etc... (yes, things are not always perfect!!) I can't understand why we cannot have a retry?

Last edited 7 years ago by narsilva (previous) (diff)
Note: See TracTickets for help on using tickets.