Opened 12 years ago

Closed 12 years ago

#279 closed defect (fixed)

oscam.user, option au = 1 does not work

Reported by: crozac Owned by: merek
Priority: major Component:
Severity: medium Keywords:
Cc: Sensitive: no

Description

If au set to value 1, user will not be able to au card.
But if the reader name is set e.g. au = cardname
user will be able to au card

also in source code there is a bug in line 729:
723 if (!strcmp(token, "au"))
724 {
725 if(value && value[0]=='1') account->autoau=1;
726 for (i=0; i<CS_MAXREADER; i++)
727 if ((reader[i].label[0]) &&
728 (!strncmp(reader[i].label, value, strlen(reader[i].label))))
729 account->au=i;
730 return;
731 }

line 729 should be
729 account->au=1;
if we follow that autoau variable should have value 1 (line 725):
725 if(value && value[0]=='1') account->autoau=1;

Bye,

Zac

Change History (3)

in reply to:  description comment:1 by merek, 12 years ago

Owner: set to merek
Status: newassigned

Replying to crozac:

If au set to value 1, user will not be able to au card.
But if the reader name is set e.g. au = cardname
user will be able to au card

also in source code there is a bug in line 729:
723 if (!strcmp(token, "au"))
724 {
725 if(value && value[0]=='1') account->autoau=1;
726 for (i=0; i<CS_MAXREADER; i++)
727 if ((reader[i].label[0]) &&
728 (!strncmp(reader[i].label, value, strlen(reader[i].label))))
729 account->au=i;
730 return;
731 }

line 729 should be
729 account->au=1;
if we follow that autoau variable should have value 1 (line 725):
725 if(value && value[0]=='1') account->autoau=1;

Bye,

Zac

comment:2 by merek, 12 years ago

Hi,

sorry, but i cannot reproduce your problem. What svn build you are using ? With current trunk line 729 seems to be a different than the code in your post.

comment:3 by alno, 12 years ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.