Opened 10 years ago

Closed 10 years ago

#2944 closed defect (fixed)

failing to read viaccess ATR on initilzation

Reported by: irishmist Owned by:
Priority: critical Component: Reader
Severity: high Keywords:
Cc: Sensitive: no

Description

Revision

R 7884 7885 7886 7887

Issue Description

I have sevceral Viaccess cards (reader mouse) with a different provider provid is failing to initialize & read entitlements on card look log error

When the issue occurs

Initialization

How the issue is reproducible

Test with mouse Viaccess JSC & Redlight both will throw the same error to concerning ATR revert back. Revert back to R 7883 all working fine including Seca

2012/11/09 13:44:52 9D94638 r red [mouse] ATR: 3F 60 3F 77
2012/11/09 13:44:52 9D94638 r red [mouse] Init card protocol T0, FI=1, F=372, D=1, N=119
2012/11/09 13:44:52 9D94638 r red [mouse] Setting baudrate to 9600 bps
2012/11/09 13:44:52 9D94638 r red [mouse] Calculated work ETU is 104.20 us
2012/11/09 13:44:52 9DB6280 r jsc [mouse] ATR: FF 03 11 E7 FF
2012/11/09 13:44:52 9DB6280 r jsc [mouse] ERROR: Could not read reader->convention
2012/11/09 13:44:52 9DB6280 r jsc [mouse] Error activating card.

Change History (23)

comment:1 by lattjo, 10 years ago

Please post debug log from the last working version as well.

comment:2 by gf, 10 years ago

What type of card reader you are using?

comment:3 by Deas, 10 years ago

at least we have now a few log lines and not like #2936...

but the best would be to read http://www.streamboard.tv/wbb2/thread.php?threadid=35600 and give theparasol the information he needs. this log is USELESS!!!

comment:4 by herr paschulke, 10 years ago

I had the same problem. Change of protocol (mouse -> smargo) solved it. Is this problem really a problem that has to be dealt with or is mouse protocol just not supported anymore?

comment:5 by Deas, 10 years ago

no, mouse protocol is supported. you should start reading and help theparasol to fix the reader initialization.

comment:6 by lattjo, 10 years ago

Try r7890.

comment:7 by irishmist, 10 years ago

I just did test R 7890 with the same result lattjo please look at the changes made in R 7884 that is where Viaccess started to fail with Smargo external readers / mouse.

Seca + NDS are not affected

comment:8 by lattjo, 10 years ago

And where is the debug log?

comment:9 by irishmist, 10 years ago

Resolution: fixed
Status: newclosed

R 7891 is OK I just tested R 7891 all Viaccess cards external smargo mouse seem to be working fine now with default settings. Although I have tested 7890 without system finding Viaccess.

Thanks to all those developers who have contributed to the resolution

comment:10 by enigma13, 10 years ago

Resolution: fixed
Status: closedreopened

R 7891 is not ok on cygwin + infinity usb smart
R7864 is ok
Closed to quick !

comment:11 by enigma13, 10 years ago

seca is OK

comment:12 by enigma13, 10 years ago

r 7884 to 7891 included fail with via card

comment:13 by enigma13, 10 years ago

20:36:55 F90C50 r infinity [mouse] card detected
20:36:57 F90C50 r infinity [mouse] ATR: 3F 77 18 00 00 C2 7A 42 02 68 90 00
20:36:57 F90C50 r infinity [mouse] Warning: D=0 is invalid, forcing D=1
20:36:57 F90C50 r infinity [mouse] Init card protocol T0, FI=1, F=372, D=1, N=
0
20:36:57 F90C50 r infinity [mouse] Calculated work ETU is 104.20 us
20:36:58 F90C50 r infinity [mouse] ATR Fsmax is: 5 Mhz, clocking card to wante
d user cardspeed of 3.57 Mhz (specified in reader->mhz)
20:36:59 F90C50 r infinity [mouse] write to cardreader
20:36:59 F90C50 87 02 00 00 03 00 00 28
20:37:02 F90C50 r infinity [mouse] failed history check
20:37:02 0 --- Skipped 1 duplicated log lines ---
20:37:02 F90C50 r infinity [mouse] card system not supported
20:37:02 F90C50 r infinity [mouse] card initializing error
20:37:02 0 s init for all local cards done
20:37:02 0 s anti cascading disabled

comment:14 by irishmist, 10 years ago

Resolution: fixed
Status: reopenedclosed

The issue of vciaccess ATR has been resolved R 7891 look at ypour log below ATR is is fine compared to my log above

20:36:57 F90C50 r infinity [mouse] ATR: 3F 77 18 00 00 C2 7A 42 02 68 90 00 === There is NO problem with ATR

comment:15 by enigma13, 10 years ago

and what is this :
20:37:02 F90C50 r infinity [mouse] failed history check
diden't exist before R7864.

I agree ATR is OK, but interpretation is not correct
Did only exist on via cards

comment:16 by lattjo, 10 years ago

I still do not see any -d255 logs anywhere? I'm sorry to say that we have no mind readers or wizards available :(

comment:17 by theparasol, 10 years ago

"failed history check" is only present in videoguard. But his card should use viaccess but doesnt for some reason. Since he is the only one complaining the error is in his setup/compiled version.

comment:18 by lattjo, 10 years ago

I agree, got the exact same error today when testing viaccess card, forgetting that I removed all reader support except the ones I use daily.

comment:19 by enigma13, 10 years ago

The result was not comming from my compiling, but the one from tekreader.
I put you a -d255 log:

12:00:07 F50D58 r infinity [mouse] IO: Receiving:
12:00:07 F50D58 FF
12:00:07 F50D58 r infinity [mouse] IO: Read timeout 1000000 us, read delay 0 u
s, to read 1 char(s), chunksize 1 char(s)
12:00:08 0 share-updater mode=initfast t=1s i=29
12:00:08 F50D58 r infinity [mouse] IO: Timeout in IO_Serial_WaitToRead, timeou
t=1000000 us
12:00:08 F50D58 r TA1 = 18
12:00:08 F50D58 r FI = 01
12:00:08 F50D58 r infinity [mouse] ATR: 3F 77 18 00 00 C2 7A 42 02 68 90 00
12:00:08 F50D58 r infinity [mouse] TA1=18 TB1=00 TC1=00 no TD1 means T0
12:00:08 F50D58 r infinity [mouse] 1 protocol types detected. Historical bytes
: C2 7A 42 02 68 90 00
12:00:08 F50D58 r infinity [mouse] No PTS happened, selected protocol T0, F=37
2, D=0, N=0
12:00:08 F50D58 r infinity [mouse] Warning: D=0 is invalid, forcing D=1
12:00:08 F50D58 r infinity [mouse] Init card protocol T0, FI=1, F=372, D=1, N=
0
12:00:08 F50D58 r infinity [mouse] Calculated work ETU is 104.20 us
12:00:08 F50D58 r infinity [mouse] IFD: Protocol: T=0, WWT=9600, Clockrate=357
0000
12:00:08 F50D58 r infinity [mouse] Setting timings: timeout=1000336 us, block_
delay=0 us, char_delay=1250 us
12:00:08 F50D58 r infinity [mouse] Setting right parity
12:00:08 F50D58 r infinity [mouse] IFD: Setting parity from Even to Odd
12:00:08 F50D58 r infinity [mouse] IO: Read timeout 1000000 us, read delay 0 u
s, to read 1 char(s), chunksize 1 char(s)
12:00:09 0 share-updater mode=initfast t=1s i=28
12:00:09 F50D58 r infinity [mouse] IO: Timeout in IO_Serial_WaitToRead, timeou
t=1000000 us
12:00:09 F50D58 r infinity [mouse] ATR Fsmax is: 5 Mhz, clocking card to wante
d user cardspeed of 3.57 Mhz (specified in reader->mhz)
12:00:09 F50D58 r infinity [mouse] IFD: Card succesfully activated
12:00:10 0 share-updater mode=initfast t=1s i=27
12:00:10 F50D58 r infinity [mouse] write to cardreader
12:00:10 F50D58 87 02 00 00 03 00 00 28
12:00:10 F50D58 r infinity [mouse] IFD: Transmit size 5 bytes, delay 0 us, tim
eout=1250 us
12:00:10 F50D58 r infinity [mouse] IFD: Transmit:
12:00:10 F50D58 87 02 00 00 03
12:00:10 F50D58 r ICC_Async_InvertBuffer: size=5 buf[0]=87
12:00:10 F50D58 r infinity [mouse] IO: Write timeout 1250 us, write delay 0 us
, to send 5 char(s), chunksize 5 char(s)
12:00:10 F50D58 r infinity [mouse] IO: Sending:
12:00:10 F50D58 1E BF FF FF 3F
12:00:10 F50D58 r infinity [mouse] IO: Write timeout 0/1250 us (max/min 0/0 us
)
12:00:10 F50D58 r ICC_Async_InvertBuffer: size=5 buf[0]=1e
12:00:10 F50D58 r infinity [mouse] IFD: Transmit succesful
12:00:10 F50D58 r infinity [mouse] IFD: Receive size 1 bytes, delay 0 us, time
out=1000336 us
12:00:10 F50D58 r infinity [mouse] IO: Read timeout 1000336 us, read delay 0 u
s, to read 1 char(s), chunksize 1 char(s)
12:00:10 F50D58 r infinity [mouse] IO: Reading 5 echoed transmitted chars...
12:00:10 F50D58 r infinity [mouse] IO: Read timeout 1000336 us, read delay 0 u
s, to read 5 char(s), chunksize 1 char(s)
12:00:10 F50D58 r infinity [mouse] IO: Read timeout 23000/1000336 us (max/min
23000/5000 us)
12:00:10 F50D58 r infinity [mouse] IO: Read timeout 6000/1000336 us (max/min 2
3000/5000 us)
12:00:10 0 --- Skipped 3 duplicated log lines ---
12:00:10 F50D58 r infinity [mouse] IO: Receiving:
12:00:10 F50D58 1E BF FF FF 3F
12:00:10 F50D58 r infinity [mouse] IO: Reading of echoed transmitted chars don
e!
12:00:11 0 share-updater mode=initfast t=1s i=26
12:00:11 F50D58 r infinity [mouse] IO: Timeout in IO_Serial_WaitToRead, timeou
t=1000336 us
12:00:11 F50D58 r ICC_Async_InvertBuffer: size=1 buf[0]=84
12:00:11 F50D58 r infinity [mouse] IFD: Receive error!
12:00:11 F50D58 r infinity [mouse] IFD: Transmit size 5 bytes, delay 0 us, tim
eout=1250 us
12:00:11 F50D58 r infinity [mouse] IFD: Transmit:
12:00:11 F50D58 87 02 00 00 03
12:00:11 F50D58 r ICC_Async_InvertBuffer: size=5 buf[0]=87
12:00:11 F50D58 r infinity [mouse] IO: Write timeout 1250 us, write delay 0 us
, to send 5 char(s), chunksize 5 char(s)
12:00:11 F50D58 r infinity [mouse] IO: Sending:
12:00:11 F50D58 1E BF FF FF 3F
12:00:11 F50D58 r infinity [mouse] IO: Write timeout 0/1250 us (max/min 0/0 us
)
12:00:11 F50D58 r ICC_Async_InvertBuffer: size=5 buf[0]=1e
12:00:11 F50D58 r infinity [mouse] IFD: Transmit succesful
12:00:11 F50D58 r infinity [mouse] IFD: Receive size 1 bytes, delay 0 us, time
out=1000336 us
12:00:11 F50D58 r infinity [mouse] IO: Read timeout 1000336 us, read delay 0 u
s, to read 1 char(s), chunksize 1 char(s)
12:00:11 F50D58 r infinity [mouse] IO: Reading 5 echoed transmitted chars...
12:00:11 F50D58 r infinity [mouse] IO: Read timeout 1000336 us, read delay 0 u
s, to read 5 char(s), chunksize 1 char(s)
12:00:11 F50D58 r infinity [mouse] IO: Read timeout 22000/1000336 us (max/min
23000/5000 us)
12:00:11 F50D58 r infinity [mouse] IO: Read timeout 6000/1000336 us (max/min 2
3000/5000 us)
12:00:11 0 --- Skipped 1 duplicated log lines ---
12:00:11 F50D58 r infinity [mouse] IO: Read timeout 5000/1000336 us (max/min 2
3000/5000 us)
12:00:11 F50D58 r infinity [mouse] IO: Read timeout 6000/1000336 us (max/min 2
3000/5000 us)
12:00:11 F50D58 r infinity [mouse] IO: Receiving:
12:00:11 F50D58 1E BF FF FF 3F
12:00:11 F50D58 r infinity [mouse] IO: Reading of echoed transmitted chars don
e!
12:00:12 0 share-updater mode=initfast t=1s i=25
12:00:12 F50D58 r infinity [mouse] IO: Timeout in IO_Serial_WaitToRead, timeou
t=1000336 us
12:00:12 F50D58 r ICC_Async_InvertBuffer: size=1 buf[0]=de
12:00:12 F50D58 r infinity [mouse] IFD: Receive error!
12:00:12 F50D58 r infinity [mouse] TRACE: ERROR: Protocol_T0_Command returns e
rror
12:00:12 F50D58 r infinity [mouse] failed history check
12:00:12 0 --- Skipped 1 duplicated log lines ---
12:00:12 F50D58 r infinity [mouse] card system not supported
12:00:12 F50D58 r infinity [mouse] card initializing error
12:00:13 0 share-update [1] 3657913523 4109466677
12:00:13 0 reported/updated +0/-0/dup 0 of 2 cards to sharelist
12:00:13 0 share-updater mode=initfast t=1s i=30
12:00:13 F50D58 r infinity [mouse] TRACE: cardreader_do_checkhealth: reader->c
ard_status = 3, ret = 0
12:00:13 0 s init for all local cards done
12:00:13 0 s anti cascading disabled
12:00:14 0 share-updater mode=initfast t=1s i=29
12:00:14 F50D58 r infinity [mouse] TRACE: cardreader_do_checkhealth: reader->c
ard_status = 3, ret = 0

Last edited 10 years ago by enigma13 (previous) (diff)

comment:20 by enigma13, 10 years ago

Same error in R 7892 and 7893

Last edited 10 years ago by enigma13 (previous) (diff)

comment:21 by enigma13, 10 years ago

same error on R7894

Perhaps title of ticket is not correct ...

Last edited 10 years ago by enigma13 (previous) (diff)

comment:22 by enigma13, 10 years ago

Resolution: fixed
Status: closedreopened

comment:23 by theparasol, 10 years ago

Resolution: fixed
Status: reopenedclosed

Perhaps you should use the forum and not hijacking tickets!

Note: See TracTickets for help on using tickets.