Opened 10 years ago

Closed 10 years ago

#2946 closed defect (fixed)

Resync error

Reported by: mado79 Owned by:
Priority: critical Component: Reader
Severity: high Keywords:
Cc: Sensitive: no

Description

Revision

<r7891>

Issue Description

<Resync error>

When the issue occurs

<oscam starts>

How the issue is reproducable

<Please fill in>

<Don't forget to ATTACH (NOT post here as text) a log file of oscam in debug mode (start oscam with -d255) and to remove the brackets around the fields! Otherwise, your ticket will be closed as you seem to be unable to read.>

Attachments (3)

oscam.log (133.0 KB ) - added by mado79 10 years ago.
oscam(r7890).log (93.1 KB ) - added by mado79 10 years ago.
oscam (r7902).log (45.9 KB ) - added by mado79 10 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 by mado79, 10 years ago

I've cecked last version, last working is r7889, then the issue is from r7890.

comment:2 by lattjo, 10 years ago

Please make a log for 7889 as well. r7890 is a good change that speeds up card init alot so we should find out why it doesn't work for you.

comment:3 by homesite, 10 years ago

You should remove the IP Adresses out of the Log !!!!!

comment:4 by mado79, 10 years ago

oscam.log uploaded! (r7889)

Last edited 10 years ago by mado79 (previous) (diff)

by mado79, 10 years ago

Attachment: oscam.log added

comment:5 by lattjo, 10 years ago

Ok now we have a r7889 log but then we need a r7890 for comparing.

comment:6 by mado79, 10 years ago

uploaded oscam.log (r7890)!

by mado79, 10 years ago

Attachment: oscam(r7890).log added

comment:7 by mado79, 10 years ago

Priority: majorcritical

comment:8 by theparasol, 10 years ago

@Lattjo: Since 7890 the readerdevice nowhere is setting ready to send, the card never (can) answer. All receive communication is in timeout only the transmitted echoed chars are read. Think you should implement a ready to send after setting parity (icc_async line 947: SetRightParity (reader); some reader devices need to get set the right parity)

comment:9 by lattjo, 10 years ago

For some reason none of my readers needs that part of the code and I don't want to re-introduce it where it was since it makes the readers release reset every time parity or something else is changed.
However I will try to make a patch where it is set only where needed. But I do not have time until tomorrow evening.

comment:10 by mado79, 10 years ago

Ok, i wait you.
bye.

comment:11 by mado79, 10 years ago

With r7902 there is the issue too!
oscam.log uploaded!

by mado79, 10 years ago

Attachment: oscam (r7902).log added

comment:13 by mado79, 10 years ago

Resolution: fixed
Status: newclosed

fixed with r7903

Note: See TracTickets for help on using tickets.