Opened 9 years ago

Closed 9 years ago

#3059 closed defect (wontfix)

Locking caid 0100:00006a

Reported by: TGFS Owned by:
Priority: critical Component: General
Severity: high Keywords:
Cc: theparasol Sensitive: no

Description

Revision

OSCAM 1.20-unstable_svn build #8090

Issue Description

Lock @ caid 100:00006a
whitlist
IDENT: 0100:000000,00006A
ECM whitelist: 0100@00006A:64
ECM HeaderWhitelist: 803061006A00075C00,813061006A00075C00,800061006A00075C00,810061006A00075C00
AU = ON
Start: 14.01.13 - 13:15:12 | UpTime: 01d 11:05:54

When the issue occurs

after a few hours the caid is giving freezes and i have to resuscitate the caid in a STB to get it working again.

the history from caid 0100:00006a is that there is a lock system on this card. You can only view 4 channels @ one moment. Or watch one channel and a other SkyLink Channel (symulcrypt issue).

How the issue is reproducable

no because i have to put the card in my STB to resuscitate the caid for about 1 a 2 hours so the lock is complete gone.

<Don't forget to ATTACH (NOT post here as text) a log file of oscam in debug mode (start oscam with -d255) and to remove the brackets around the fields! Otherwise, your ticket will be closed as you seem to be unable to read.>

Attachments (2)

oscam.log (89.1 KB ) - added by TGFS 9 years ago.
oscam.server (875 bytes ) - added by TGFS 9 years ago.

Download all attachments as: .zip

Change History (11)

by TGFS, 9 years ago

Attachment: oscam.log added

by TGFS, 9 years ago

Attachment: oscam.server added

comment:1 by TGFS, 9 years ago

[LOG323]2013/01/16 00:40:35 9B4CEC0 r ratelimiter find a slot for srvid 521C on reader kaart-basishd reader_mode = 1
[LOG324]2013/01/16 00:40:35 9B4CEC0 r ratelimiter found srvid 521C for 3 sec in slot #1/4 of reader kaart-basishd
[LOG325]2013/01/16 00:40:35 9B4CEC0 r ecm:
[LOG326]2013/01/16 00:40:35 9B4CEC0 81 30 61 00 6A 00 07 5C 00 BB 7D F9 99 3A D5 21
[LOG327]2013/01/16 00:40:35 9B4CEC0 4B B1 80 4D A1 F4 C6 36 C1 AC AF FC 02 31 E6 EA
[LOG328]2013/01/16 00:40:35 9B4CEC0 FE D8 0E C5 C9 EE 3A 50 F8 B3 14 A0 6E BA 02 4B
[LOG329]2013/01/16 00:40:35 9B4CEC0 A7 F5 53 4F 0B 6E 7B 18 7B 25 F1 10 BD 7A 44 88
[LOG330]2013/01/16 00:40:35 9B4CEC0 D7 AE FC 79 6D DC D5 78 2F E8 6A 52 88 03 87 0A
[LOG331]2013/01/16 00:40:35 9B4CEC0 E4 79 8C C3 3E 32 66 52 CA AA 27 43 A4 3D AC B0
[LOG332]2013/01/16 00:40:35 9B4CEC0 1F C7 79 9E
[LOG333]2013/01/16 00:40:35 9B4CEC0 r card1 [seca] cardreader_do_checkhealth: reader->card_status = 2, ret = 1
[LOG334]2013/01/16 00:40:35 9B4CEC0 r card1 [seca] cardreader_do_ecm: cardreader_do_checkhealth returned rc=1
[LOG335]2013/01/16 00:40:35 9B4CEC0 r card1 [seca] write to cardreader
[LOG338]2013/01/16 00:40:35 9B4CEC0 C5 C9 EE 3A 50 F8 B3 14 A0 6E BA 02 4B A7 F5 53
[LOG365]2013/01/16 00:40:35 9B4CEC0 7B 25 F1 10 BD 7A 44 88 D7 AE FC 79 6D DC D5 78

comment:2 by theparasol, 9 years ago

ratelimitseconds = 3000

50 minuts for ratelimitseconds is total wrong.
Stick to ratelimitecm =4, ratelimitseconds = 10
Additional: cooldown 60,600 (usefull for quick zapping / low normal card usage)

And even then on certain channels (common those without emmpid) the cardlock is reported to lock on 2 instead of 4 ecms / 10s

comment:3 by TGFS, 9 years ago

@theparasol

I have set 2 SIDS one card because the lock problem is comming anytime back

521C : Net 5 HD = normal channel (no skylink)
07FA : Hustler TV (skylink channel)

If i set:
Ratelimit ECM: 4 ## with 4 SIDS
Ratelimit seconds: 10

I get a cardlock

If i set:
Ratelimit ECM: 2 ## with 2 SIDS
Ratelimit seconds: 10

I get a cardlock

The problem looks to me that OSCAM checks @ the SID from Skylink and then the card is thinking limit 4 SIDS @ one time. If i set 4 SkyLink SIDS permanent set and using the option services and total 4 SIDS are ask @ one time then the card lock is a fact.
The card is thinking that i am using more then 4 channels @ one time and that's not what i am doing. I hope you understand all of this...

0100:1421

EUROSPORT 19,2 07E9

Hustler TV 19,2 07FA

Eurosport HD 23,5 1421

HISTORY HD 23,5 141F

Discovery HD Showcase 23,5 1B62

BravaHDTV 23,5 1B71

Penthouse HD 23,5 1B7D

Private Spice (Dutch) 23,5 333C (changed i think)

NGC Wild 23,5 1419

History Channel (TVV) 23,5 13D4

Travel Channel HD 23,5 13C0

JIM JAM 23,5 334F

Duck tv 23,5 1415

Eurosport HD2 (Dutch) 23,5 13C9

Last edited 9 years ago by TGFS (previous) (diff)

comment:4 by TGFS, 9 years ago

And you telling: cooldown 60,600

is it
cooldown: 60 or 600
or
cooldown: 60,600 ?

comment:5 by TGFS, 9 years ago

Cooldown Delay: 60
Cooldown Time: 600

is not the solution theparasol, if i can use 4 SIDS normal @ one card. Why is this card not get a lock and a card with 2 SIDS where one SID is a SkyLink SID a lock?
(and i use the same setup)

[reader]
label = card1
protocol = smartreader
device = 002:008
services = card1,!card1
smargopatch = 1
caid = 0100
ecmwhitelist = 0100@00006A:64
ecmheaderwhitelist = 803061006A00075C00,813061006A00075C00,800061006A00075C00,810061006A00075C00
detect = cd
mhz = 343
cardmhz = 357
ident = 0100:000000,00006A
group = 1
emmcache = 1,3,2
blockemm-unknown = 1
blockemm-g = 1
lb_weight = 300
dropbadcws = 1
disablecrccws = 1
ratelimitecm = 4
ratelimitseconds = 10

[reader]
label = card2
protocol = smartreader
device = infinity;002:004
services = card2,!card2
caid = 0100
ecmwhitelist = 0100@00006A:64
ecmheaderwhitelist = 803061006A00075C00,813061006A00075C00,800061006A00075C00,810061006A00075C00
detect = cd
mhz = 480
cardmhz = 357
ident = 0100:000000,00006A
group = 1
emmcache = 1,3,2
blockemm-unknown = 1
blockemm-g = 1
lb_weight = 300
dropbadcws = 1
disablecrccws = 1
ratelimitecm = 4
ratelimitseconds = 10

comment:6 by theparasol, 9 years ago

This all is known already. What not known is how to fix / workaround it.
We cannot change the firmware of the card, if it locks: it locks.
The 4 channel lock was public spread knowledge not based on facts, you cannot take it for granted.

comment:7 by TGFS, 9 years ago

I understand... the mainproblem is this:

I do have it only with simulcrypt SIDS on card 0100:00006a and my beliefs are you could bould something for it in OSCAM.

If i have 4 normal SIDS @ one card

example:

- 1B6C : RTL 4 HD
- 5217 : RTL 5 HD
- 17CA : SBS 6 HD
- 5212 : RTL 7 HD

and if i would record RTL4HD, RTL5HD, SBS6HD and watch RTL7HD there is no problem at all
only if you take 4 simulcrypt channels like:

example:

- 1419 : NG Wild
- 1421 : Eurosport HD
- 1B62 : Discovery HD Showcase
- 141F : History HD

A problem that i think it could be is this option not working fine

  • ECM whitelist: 0100@00006A:64
  • ECM headerWhitelist: 813061006A00075C00,803061006A00075C00

Why? Because if you take 0100@00006A:64 this is only for Canaldigitaal for no other provider. So if there were no ECM whitelist / ECM headerWhitelist than i can think ok i understand maybe this examples. Now there is ECM whitelist / ECM headerWhitelist then can't be that you get a lock.

There must be a solution Dr. theparasol

Knowledge is realizing that the street is one-way, wisdom is looking both directions anyway

Kind regards, TGFS


Last edited 9 years ago by TGFS (previous) (diff)

comment:8 by Admin, 9 years ago

The locking happens because of too many parallel requests happening. What should this have to do with ecm whitelist?
The card simply gets locked because the card firmware has some internal logic that limits watching multiple channels at once and some channels are rated other than other channels regarding those limits (perhaps the real limit is somehow calculated by the processing time that the card needs and not the amount of SIDs). This logic can even be changed by your provider. In my mind, the only possibility is
a) find values for ratelimiter that even work with the bad channels
b) disable the bad channels through services or use a second card for them with different values for ratelimiter

I don't see what we should do here. Implementing a system which does the same calculations as the card for rateliming is probably near to impossible.

comment:9 by Deas, 9 years ago

Resolution: wontfix
Status: newclosed

if you want to discuss the ratelimiter, do it in the forum with theparasol, not here. nothing we can do in oscam when the card locks.

Note: See TracTickets for help on using tickets.