Opened 10 years ago

Closed 10 years ago

#3090 closed defect (fixed)

Services are not parsed for readers with case sensitive scenarios

Reported by: szili_boy Owned by:
Priority: critical Component: Reader
Severity: medium Keywords:
Cc: Sensitive: no

Description

Revision

8180 upwards

Issue Description

Because reader settings parser became case sensitive services from oscam.services are not asociated to readers. Here is the exact scenario:

In oscam.services I have this:

[Digi RO Popular]
CAID = 1802,1880
ProvID = ...
SrvID = ...

In WebIF it is parsed in lowecase like this: digi ro popular.

In oscam.reader I have this under [reader] section.

Services = Digi RO Popular

Because the parser is case sensitive now it does not recognize 'Digi RO Popular' so no services will be associated to the reader
Please note that this way worked ok with pre 8075 builds.
It associates only if I have this:

Services = digi ro ropular

When the issue occurs

Always if there are case sensitive service list names are used.

How the issue is reproducable

Always with the above scenario. I think than no log is needed, everyone can simulate this. Tested on DM800SE OE1.6, but I think its platform independent and as far as I know oscam.services parsing does not use generic parsing so thats why it parses in lowercase.

<Don't forget to ATTACH (NOT post here as text) a log file of oscam in debug mode (start oscam with -d255) and to remove the brackets around the fields! Otherwise, your ticket will be closed as you seem to be unable to read.>

Change History (2)

comment:1 by gf, 10 years ago

Please try r8190.

comment:2 by szili_boy, 10 years ago

Resolution: fixed
Status: newclosed

8190 is working fine again, thanks @gf

Note: See TracTickets for help on using tickets.