Opened 9 years ago

Closed 9 years ago

#3117 closed defect (fixed)

oscam crashes silently when saving oscam.srvid from webif

Reported by: imperia Owned by: alno
Priority: minor Component: Webinterface
Severity: low Keywords:
Cc: Sensitive: no

Description

Revision

8243

Issue Description

When I try to save oscam.srvid file from WebIf, Oscam crashes silently. In logs I only see:
"280 service-id's loaded in 6ms" even with full debugging enabled.
By the time WebIf tries to reload itself, Oscam has already crashed.

Few days ago everything was working fine.
I also tried to Cut (CTRL-X) the content of oscam.srvid and then Save, but it still crashes even with empty file. So the changes are saved and reloaded, and then Oscam crashes.

How the issue is reproducable

WebIf -> FILES -> oscam.srvid - Click Save

Attachments (2)

oscam.srvid (13.7 KB ) - added by N3m3515 9 years ago.
oscam.2.srvid (20.1 KB ) - added by imperia 9 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 by N3m3515, 9 years ago

got the same issue with r8218
looks like its faulty since some releases

comment:2 by ni hao, 9 years ago

Indeed webif crashes then but oscam is still running.

comment:3 by imperia, 9 years ago

I just checked it. On my xtrend 6000 oscam is crashing.
I mean that when I do "ps | grep oscam" process disappears.
I have to restart it from the receiver's UI.

comment:4 by gf, 9 years ago

Please attach your oscam.srvid.

by N3m3515, 9 years ago

Attachment: oscam.srvid added

by imperia, 9 years ago

Attachment: oscam.2.srvid added

comment:5 by imperia, 9 years ago

"I also tried to Cut (CTRL-X) the content of oscam.srvid and then Save, but it still crashes even with empty file."

comment:6 by imperia, 9 years ago

I am experiencing something very strange that I have just noticed and I think it may be related.
Lets say I have 2 readers. One (reader1) for provider with CAID 1234, and other (reader2) with multiple providers including provider with CAID 1234. I don't want my Oscam to use reader2 for CAID 1234, so I excluded it by using "services=!some_provider" in oscam.server file. This filter is working for some channels, but for others it isn't!!! For some channels it picks CWs from both readers. I've spent 30 minutes on comparing different lines in oscam.srvid. For the ones that filtering is working are exactly the same as the ones that aren't working (except the name ofcourse). In oscam.srvid everything is fine, so there must be some problem with filtering.

comment:7 by Admin, 9 years ago

oscam.srvid is not for filtering (don't mix oscam.srvid with oscam.services!) so you are completely wrong here.

The error in this ticket should be fixed with r8245.

comment:8 by Admin, 9 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.