Opened 12 years ago

Closed 12 years ago

#319 closed defect (fixed)

Problem with oscam-mon entitlement not shown correctly

Reported by: _ps7ch0_ Owned by: alno
Priority: minor Component:
Severity: low Keywords: oscma-mon
Cc: Sensitive: no

Description

Hello,

This is a little issue about the entitlement.

From the web interface, I received only the three fisrt lines

ATR: 3B F7 11 00 01 40 96 70 70 37 0E 6C B6 D6

type: seca, caid: 0100, serial: xxxxxxxxx, card: Canal+ NL v7.3
providers: 5 (0000,009B,009C,009D,009E)

But these lines don't show me my current entitlement because this one appears later. (line 4)

2010/01/08 14:39:22 16783 r03 ATR: 3B F7 11 00 01 40 96 70 70 37 0E 6C B6 D6

2010/01/08 14:39:23 16783 r03 type: seca, caid: 0100, serial: xxxxxxxxx, card: Canal+ NL v7.3

2010/01/08 14:39:23 16783 r03 provider: 1, valid: 0, name: SECA, expiry date: 1990/00/00

2010/01/08 14:39:23 16783 r03 provider: 2, valid: 1, name: BETV, expiry date: 2010/02/28

2010/01/08 14:39:23 16783 r03 SA: 001B15E1

2010/01/08 14:39:23 16783 r03 provider: 3, valid: 0, name: CANAL+ VL, expiry date: 2003/12/31

2010/01/08 14:39:23 16783 r03 provider: 4, valid: 0, name: Spare A, expiry date: 1990/00/00

2010/01/08 14:39:23 16783 r03 provider: 5, valid: 0, name: Spare B, expiry date: 1990/00/00

2010/01/08 14:39:23 16783 r03 providers: 5 (0000,009B,009C,009D,009E)
...

Cheers.

Attachments (2)

screenshot_01.jpg (35.4 KB ) - added by _ps7ch0_ 12 years ago.
Web Interface
screenshot_02.jpg (181.5 KB ) - added by _ps7ch0_ 12 years ago.
oscam.log

Download all attachments as: .zip

Change History (7)

comment:1 by alno, 12 years ago

Resolution: worksforme
Status: newclosed

The Entitlement is nothing else as the startlog of your reader stored in the memory. The Webinterface only present this piece of log. It should be the same as you see on ascam startup on your console

by _ps7ch0_, 12 years ago

Attachment: screenshot_01.jpg added

Web Interface

by _ps7ch0_, 12 years ago

Attachment: screenshot_02.jpg added

oscam.log

comment:2 by _ps7ch0_, 12 years ago

Resolution: worksforme
Status: closedreopened

Hello Alno,

Herewith two screenshots in order to identify my current issue. Let me know if it's "normal behaviour". But I think no.

Thanks.

comment:3 by alno, 12 years ago

it's a seca reader and by design of code it shows only valid entitlements

reader-seca.c line 64ff

 if (valid==1) //if not expired
    cs_log("SA: %s", cs_hexdump(0, cta_res+18, 4));

I'll not change smthg. in the reader modules. If you need it for you personally comment out or delete the line if (valid==1) if not expired

comment:4 by alno, 12 years ago

sorry wrong codepart - the entitlement for monitor usage is written here in line 102

  cs_ri_log("type: seca, caid: %04X, serial: %llu, card: %s v%d.%d",
         reader[ridx].caid[0], serial, card, atr[9]&0x0F, atr[9]>>4);
  read_cmd(ins16, NULL); // read nr of providers

This is after the decission is made and invalid carddata already filtered out.

This is smthg. what I deffinately not able and willing to fix because hundred other guys will ask then why now invalid entitlements are showed

comment:5 by _ps7ch0_, 12 years ago

Resolution: fixed
Status: reopenedclosed

Ok no prob. Thanks for your reply... and great job also on the top. I am going to close this.

Note: See TracTickets for help on using tickets.