Opened 9 years ago

Closed 8 years ago

#3193 closed defect (wontfix)

Unpair Irdeto card camkey camdata problem

Reported by: tayab Owned by:
Priority: critical Component: Card support
Severity: high Keywords:
Cc: Sensitive: no

Description

Revision

<1.20 All Versions>

Issue Description

<I have an Irdeto-2 unpair card which was working well few months ago but now provider did ome changes due to which now card is not working at all. It seems some kind of EMM's not updating issue because card work well in any original box from original provider. Cam Keys and Cam Data keys also not changed and they are same as they were before this issue as I extracted the Cam Keys & Cam Data Keys from card again and they were same>

When the issue occurs

<Almost 2 months before this issue started>

How the issue is reproducable

<Everytime when I try to open any channel it shows "not ok" msg>

<oscam gives Error:

03:07:29 978DD68 r sun [irdeto] IO: Receiving:
03:07:29 978DD68 01 05 33 00 00 00 02 00
03:07:29 978DD68 r sun [irdeto] IFD: Receive succesful
03:07:29 978DD68 r sun [irdeto] IFD: Setting timeout to 892800 ETU (83030400 us)
03:07:29 978DD68 r sun [irdeto] IFD: Receive size 1 bytes, delay 0 us, timeout=83030400 us
03:07:29 978DD68 r sun [irdeto] IO: Read timeout 83030400 us, read delay 0 us, to read 1 char(s), chunksize 1 char(s)
03:07:29 978DD68 r sun [irdeto] IO: Receiving:
03:07:29 978DD68 0A
03:07:29 978DD68 r sun [irdeto] IFD: Receive succesful
03:07:29 978DD68 r sun [irdeto] Answer from cardreader:
03:07:29 978DD68 33 00
03:07:29 978DD68 r sun [irdeto] cardreader_do_ecm: after csystem.do_ecm rc=0
03:07:29 978DD68 r sun [irdeto] cardreader_do_ecm: ret rc=0
03:07:29 978DD68 r sun [irdeto] cardreader_process_ecm: cardreader_do_ecm returned rc=0 (ERROR=0)
03:07:29 978DD68 r sun [irdeto] Error processing ecm for caid 0649, srvid 0012, servicename: 0649:0012 unknown
03:07:29 978DD68 r sun [irdeto] ecm hash: 8C10017BB9AE539722C655BBD735AB08 real time: 267 ms
03:07:29 978DD68 r add client job action 24 queue length 1 try
03:07:29 97AE250 c poll() timeout
03:07:29 97AE250 c sun [irdeto] TRACE: ecm answer for ecm hash 8C10017BB9AE539722C655BBD735AB08 rc=4
03:07:29 97AE250 c request_cw stage=4 to reader sun ecm hash=8C10017BB9AE539722C655BBD735AB08
03:07:29 97AE250 c start reader thread action 5
03:07:29 97AE250 c ncd_send_dcw: er->msgid=0, cl_msgid=0, 80
03:07:29 97AE250 c send 15 bytes to client
03:07:29 97AE250 00 0D 00 00 00 00 00 00 00 00 00 00 80 00 00
03:07:29 978DD68 r data from add_job action=5 client r sun
03:07:29 978DD68 r sun [irdeto] TRACE: skip ecmhash 8C10017BB9AE539722C655BBD735AB08, rc=4
03:07:29 97AE250 c try (0649&000000/0035/0012/44:8C10017BB9AE539722C655BBD735AB0cool : not found (267 ms) by sun (sun irdeto_do_cmd [2] 33 00)>

Attachments (1)

sun.zip (12.4 KB ) - added by newcslover 9 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 by tayab, 9 years ago

Component: Please fill inCard support
Priority: Please fill incritical
Severity: Please fill inmedium

comment:2 by fa5ades, 9 years ago

I wish there was a solution in this, we are more than 1 year with this prob with greek provider nova and noone yet found a real community solution because some solutions exist but doesnt appear in public.

comment:3 by tayab, 9 years ago

I also wonder why OSCAM team is so much in fear that they even didn't added tweak keys source code in OSCAM yet.

comment:4 by gf, 9 years ago

Talk is cheap. Send patches.

comment:5 by malakudi, 9 years ago

Please post season log from card working in receiver.

comment:6 by buset1974, 9 years ago

Dear GF, yes we also have the same problem with our provider 0604, we should use some kind of tweak keys, right now we are using old compiled version of oscam tweaked and it's version is way behind, I am really sorry that I don't have any information regarding the patch involved, but I think the 'tweak things' is part of irdeto-2 algorithm/ protection. I will inform you soonest we have another information regarding this problem.

comment:7 by newcslover, 9 years ago

Severity: mediumhigh
Summary: Unpair Irdeto card update problemUnpair Irdeto card camkey camdata problem

irdeto_do_cmd [2] 33 00 >> wrong set of camkey and camdata

we need to find out new camkey and camdata

here is the card file 2 and 3 if someone can plz decrypt it for camkey and camdata:

TX <- 01 02 0E 02 00 00 30

RX -> 01 02 00 00 0E 02 00 40 9B 9A E2 71 CB 87 12 1C 67 7A 5B AC 9B 52 E0 70 15 9C FF F6 60 87 FB AB A6 2F E8 E9 8B 52 36 0B 22 47 CD E5 F6 CD C8 B8 15 05 61 90 27 BD FE 51 CD EE D8 F0 5E 10 71 20 18 80 A2 28 4A 3E 2A DD 1F

TX <- 01 02 0E 03 00 00 31

RX -> 01 02 00 00 0E 03 00 40 3D 72 C6 58 F0 36 EF 09 F5 A5 8D FB 61 5D 0B BA F9 D7 24 77 31 53 7E EE 4B 96 4D 3A C1 CE C9 2A DA 59 62 34 01 70 27 4F A8 59 AE 38 04 80 9B 91 5A F9 F7 95 9A E2 71 7C 11 13 27 09 23 8A 9E 65 0D

oscam -d255 log attached

by newcslover, 9 years ago

Attachment: sun.zip added

comment:8 by fun7, 8 years ago

Resolution: wontfix
Status: newclosed

Ticketsystem is not a platform on how to find out your pairing data. You gotta get this info outta your STB / Cam Flash.

Note: See TracTickets for help on using tickets.