Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#3201 closed defect (fixed)

Card reader Error - Nagra3 - 142

Reported by: altair1973 Owned by: altair1973
Priority: critical Component: Reader
Severity: high Keywords:
Cc: jpt_mir@… Sensitive: no

Description

Revision

<7963>

Issue Description

<Card reader detect ATR, but not start...>

When the issue occurs

<Card reader activate>

How the issue is reproducable

<Restart Card reader>

I have a receiver Medi@Link Ixuss One and cant enable Nagra3 Card....

here is the log of oscam with 255:

2013/02/27 04:13:38 585848 h HTTP Server listening on port 89
2013/02/27 04:13:38 583BF8 r data from add_job action=8 client r zon
2013/02/27 04:13:38 583BF8 r zon [internal] IFD: Opening device /dev/sci0
2013/02/27 04:13:38 583BF8 r zon [internal] IFD: Device /dev/sci0 succesfully opened
2013/02/27 04:13:38 583BF8 r zon [internal] Reader initialized (device=/dev/sci0, detect=cd, mhz=368, cardmhz=368)
2013/02/27 04:13:38 583BF8 r zon [internal] card detected
2013/02/27 04:13:38 583BF8 r add reader job action 4 queue length 1 zon
2013/02/27 04:13:38 583BF8 r zon [internal] TRACE: cardreader_do_checkhealth: reader->card_status = 1, ret = 0
2013/02/27 04:13:38 583BF8 r zon [internal] IFD: Activating card
2013/02/27 04:13:38 0 --- Skipped 1 duplicated log lines ---
2013/02/27 04:13:38 583BF8 r zon [internal] IFD: Is card activated?
2013/02/27 04:13:38 583BF8 r zon [internal] IFD: Reset internal cardreader!
2013/02/27 04:13:40 583BF8 r zon [internal] IFD: Waiting for card ATR Response...
2013/02/27 04:13:43 0 --- Skipped 71620 duplicated log lines ---
2013/02/27 04:13:43 585848 h WebIf: Origin checked. Result: access from 192.168.10.2 => allowed
2013/02/27 04:13:43 583BF8 r zon [internal] IFD: Waiting for card ATR Response...
2013/02/27 04:13:43 0 --- Skipped 2130 duplicated log lines ---
2013/02/27 04:13:43 585848 h WebIf: Received stale header from 192.168.10.2.
2013/02/27 04:13:43 583BF8 r zon [internal] IFD: Waiting for card ATR Response...
2013/02/27 04:13:43 0 --- Skipped 540 duplicated log lines ---
2013/02/27 04:13:43 585848 h WebIf: Origin checked. Result: access from 192.168.10.2 =>

Change History (10)

comment:1 by altair1973, 8 years ago

2013/02/27 04:16:57 0 s waiting for local card init
2013/02/27 04:16:57 585440 r zon [internal] Reader initialized (device=/dev/sci0, detect=cd, mhz=368, cardmhz=368)
2013/02/27 04:16:57 583BF8 h HTTP Server listening on port 89
2013/02/27 04:16:58 585440 r zon [internal] card detected
2013/02/27 04:16:59 585440 r zon [internal] ATR: 3F FF 95 00 FF 91 81 71 FE 47 00 44 4E 41 53 50 31 34 32 20 52 65 76 47 30 34 10
2013/02/27 04:16:59 585440 r zon [internal] Init card protocol T1, FI=9, F=512, D=16, N=255
2013/02/27 04:16:59 585440 r zon [internal] Setting baudrate to 115200 bps
2013/02/27 04:16:59 585440 r zon [internal] Calculated work ETU is 8.70 us
2013/02/27 04:16:59 585440 r zon [internal] ATR Fsmax is: 5 Mhz, clocking card to 3.68
2013/02/27 04:16:59 585440 r zon [internal] Warning: Card returned error on setting ifsd value to 251
2013/02/27 04:17:00 585440 r zon [internal] detect native nagra card
2013/02/27 04:17:00 585440 r zon [internal] Resync error: readtimeouts 54/9 (max/min) us, writetimeouts 0/0 (max/min) us
2013/02/27 04:17:00 585440 r zon [internal] T1 Resync command error, trying to reactivate!

comment:2 by gf, 8 years ago

  1. Use the latest version, 7963 is about ~450 commits old.
  2. You haven't posted your reader config.
    • The mhz/cardmhz looks suspicious:
      Reader initialized (device=/dev/sci0, detect=cd, mhz=368, cardmhz=368
      
  3. You haven't mentioned the last version that worked for you.

comment:3 by altair1973, 8 years ago

version i use: OSCAM 1.20-unstable_svn build #7963
that same as you mentioned

oscam.server:

[reader]
label = zon
enable = 1
protocol = internal
device = /dev/sci0
key = 0102030405060708091011121314
caid = 1802
rsakey = 123567C503BB0DB11632A8DC990B98D73D45D155CAXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
boxkey = 11185XXXXX334XXXXXXXXX
detect = cd
mhz = 368
cardmhz = 368
group = 1
emmcache = 1,3,31

I have alreasy tested with other mhz seeting and the error is the same

comment:4 by altair1973, 8 years ago

image details:
Welcome to OpenEmbedded Linux OE-Alliance 3.0 ixussone
Linux mips 3.3.0 #1 SMP Mon Feb 18 15:19:12 CET 2013

root@ixussone:~# cat /proc/cpuinfo
system type : BCM7413B1 STB platform
processor : 0
cpu model : Brcm4380 V4.4 FPU V0.1
BogoMIPS : 403.45
cpu MHz : 405.000
wait instruction : yes
microsecond timers : yes
tlb_entries : 32
extra interrupt vector : yes
hardware watchpoint : no
ASEs implemented : mips16
shadow register sets : 1
kscratch registers : 0
core : 0
VCED exceptions : not available
VCEI exceptions : not available

processor : 1
cpu model : Brcm4380 V4.4 FPU V0.1
BogoMIPS : 405.50
cpu MHz : 405.000
wait instruction : yes
microsecond timers : yes
tlb_entries : 32
extra interrupt vector : yes
hardware watchpoint : no
ASEs implemented : mips16
shadow register sets : 1
kscratch registers : 0
core : 0
VCED exceptions : not available
VCEI exceptions : not available

comment:5 by altair1973, 8 years ago

Cc: jpt_mir@… added
Owner: set to altair1973
Status: newassigned

comment:6 by altair1973, 8 years ago

can someone help?

comment:7 by Deas, 8 years ago

try an external usb reader, try to play around with the mhz and cardmhz settings. it could be that this box has the same "problem" as dreambox receivers: http://www.streamboard.tv/wiki/OSCam/en/Config/oscam.server#cardmhz

comment:8 by fun7, 8 years ago

Problem might be the result of the fixed frequency of the internal reader. Would recommend to try the dreambox patch.

comment:9 by Deas, 8 years ago

Resolution: fixed
Status: assignedclosed

no update => closed...

in reply to:  description comment:10 by sirgodha, 7 years ago

Hi, I want to know about oscam r9825 a card on it dont work some time it works some time when take off of it then issue my one card dont work not sure any suggestion to fix it

Note: See TracTickets for help on using tickets.