Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#3202 closed defect (fixed)

tplfooter rev. 3484 is broken

Reported by: Netview Owned by:
Priority: Please fill in Component: ! Please select...
Severity: Please fill in Keywords:
Cc: Sensitive: no

Description

tplfooter is defined as (pages.c):

#define TPLFOOTER \
" <BR><HR><BR>\n\

<DIV CLASS=\"footer\">\n\

<H4 CLASS=\"footline1\">OSCAM Webinterface developed by Streamboard Team - ##CURDATE## ##CURTIME## | Access from ##CURIP##</H4>\n\
<H4 CLASS=\"footline2\">Start: ##STARTDATE## - ##STARTTIME## | UpTime: ##UPTIME## | Process ID: ##PROCESSID##</H4>\n\
<H4 CLASS=\"styleauthor\">WebIf Style by </H4>\n\

</DIV>\n\

</BODY>\n\
</HTML>\n"

This is shown:
OSCAM Webinterface developed by Streamboard Team - 27.02.13 14:38:24 | Access from 10.0.0.5

Start: 27.02.13 - 14:36:56 |

no uptime, no process-id, no style-author

Attachments (3)

r8437.png (11.9 KB ) - added by gf 8 years ago.
I can't reproduce this, it seems just fine here on r8437.
pages.c (178.5 KB ) - added by Netview 8 years ago.
Webif.png (9.8 KB ) - added by Jan Gruuthuse 8 years ago.
webif footer showing in r8438

Download all attachments as: .zip

Change History (11)

by gf, 8 years ago

Attachment: r8437.png added

I can't reproduce this, it seems just fine here on r8437.

comment:1 by Netview, 8 years ago

{ .tpl_name="FOOTER", .tpl_data=TPLFOOTER, .tpl_deps="", .tpl_data_len=350 },

350 chars?
Maybe this is to short?

comment:2 by gf, 8 years ago

Maybe not...

gf@gf:~/git/oscam/webif$ ls -l include/footer.html
-rw-r--r-- 1 gf users 350 Feb 24 17:12 include/footer.html

comment:3 by Netview, 8 years ago

If have increased it to 400 and the footer is completely shown.

comment:4 by gf, 8 years ago

Increasing it to 400 is a serious bug.

Something is missing. Do you use custom templates? Do you have changes in templates? what is different that standard oscam-svn in your case, bacause as I have demonstrated there is no bug here on my machine.

Attach the generated pages.c

Also save the generated status.html page from your browser and attach it here.

Last edited 8 years ago by gf (previous) (diff)

by Netview, 8 years ago

Attachment: pages.c added

comment:5 by Netview, 8 years ago

no custom-templates!

and where is the last-line:

<H4 CLASS=\"styleauthor\">WebIf Style by </H4>\n\

Eneen?

It is not a part of your r8437.png (but it is still inside pages.c and hidden)

by Jan Gruuthuse, 8 years ago

Attachment: Webif.png added

webif footer showing in r8438

comment:6 by Netview, 8 years ago

Resolution: fixed
Status: newclosed

ok - Problem solved in 8438 tx!

comment:7 by Netview, 8 years ago

Last edited 8 years ago by Netview (previous) (diff)

comment:8 by gf, 8 years ago

Nothing have changed, what was the problem?

Note: See TracTickets for help on using tickets.