Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#3209 closed defect (fixed)

extended newcamd does not work anymore

Reported by: Mo0211 Owned by: gf
Priority: critical Component: Protocol - Newcamd
Severity: high Keywords: extended newcamd
Cc: Sensitive: no

Description

Revision

from r8455 and later

Issue Description

with struct-changes the extended newcamd does not work anymore
Error:

rejected lserver ident (0 ms) (0/0/0/0) - N24 HD (no server match 1843:000000)

see http://www.streamboard.tv/wbb2/thread.php?threadid=37446

When the issue occurs

mgclient option is checked

How the issue is reproducable

Set mgclient-option and use newcamd-protocol to watch channels on different caids

<Don't forget to ATTACH (NOT post here as text) a log file of oscam in debug mode (start oscam with -d255) and to remove the brackets around the fields! Otherwise, your ticket will be closed as you seem to be unable to read.>

Attachments (3)

OScam.log (1.0 MB ) - added by Mo0211 9 years ago.
Log
oscam.conf (2.3 KB ) - added by Mo0211 9 years ago.
oscam.conf
oscam.server (4.3 KB ) - added by Mo0211 9 years ago.
oscam.server

Download all attachments as: .zip

Change History (14)

comment:1 by gf, 9 years ago

Let me try to understand this:

r8454 - works
r8455 - do not work
r8469 - do not work (latest from now)

correct?

comment:2 by Mo0211, 9 years ago

yes, thats correct!

Thanks for your support :)

Last edited 9 years ago by Mo0211 (previous) (diff)

comment:3 by gf, 9 years ago

Please attach you oscam.server and oscam.conf config files. Looking at the commit I can't see what can break because of it, will look further.

comment:4 by gf, 9 years ago

And post debug log with -d 255

by Mo0211, 9 years ago

Attachment: OScam.log added

Log

by Mo0211, 9 years ago

Attachment: oscam.conf added

oscam.conf

by Mo0211, 9 years ago

Attachment: oscam.server added

oscam.server

comment:5 by Mo0211, 9 years ago

done - hope this helps!
1702 works, because the newcamd-port is configured with 1702 as caid and ident.

comment:6 by dropsman, 9 years ago

@Mo0211:
This is a working config file right?

Normally you use such a line:
Port = 33333@1702:000000;1722:000000;1843:000000;0B00:000000

All caid's on 1 port with the extended newcamd protocol.

comment:7 by Mo0211, 9 years ago

@dropsman:

Yes, this is a working config.
This Config works with Rev8454.
I remember only, that i have to define services for the user that he knows which caids are available.

comment:8 by gf, 9 years ago

I have a suspicion. Does this help:

diff --git a/oscam-chk.c b/oscam-chk.c
index 3c08404..5913ef6 100644
--- a/oscam-chk.c
+++ b/oscam-chk.c
@@ -376,7 +376,7 @@ int32_t chk_sfilter(ECM_REQUEST *er, PTAB *ptab)
   prid = er->prid;
   pi = cur_cl->port_idx;
 
-  if (cfg.ncd_mgclient && ptab == &cfg.ncd_ptab)
+  if (cfg.ncd_mgclient)
      return 1;
 
   if (ptab->nports && ptab->ports[pi].ncd && ptab->ports[pi].ncd->ncd_ftab.nfilts)

comment:9 by dukynukem, 9 years ago

Yes it works. thx

comment:10 by gf, 9 years ago

Resolution: fixed
Status: newclosed

Fix committed in r8470.

comment:11 by Mo0211, 9 years ago

thanks for your help gf!
it does work.

Note: See TracTickets for help on using tickets.