Opened 9 years ago

Closed 9 years ago

#3222 closed defect (fixed)

SRG via5 EMM no longer working in Trunk with Acamd and emmreassembly = 0

Reported by: MadMaxx Owned by:
Priority: minor Component: Reader
Severity: medium Keywords: VIA5 EMM
Cc: Sensitive: no

Description

In actual trunk it looks like EMMs for Via5/SRG is no longer working.

I see in Webinterface only skipped shared EMMs after a fresh start
of oscam + the 1 "usual Update-Error 9400 EMM"

For the Update ACamd/newcamd is used and emmreassembly = 0 is set on the local via5-reader, but nothing else is changed between the last 3 weeks at the config itself.

Maybee something forgotten by all the "private arrays" movings the last days that has an impact on "emmreassembly" or Viaccess itself ?

Can someone else please check with MGcamd and/or ACamd SRG via4 and via5 cards for working EMM by using "emmreassembly = 0" setted on local cardreader please ?

Change History (7)

comment:1 by Jan Gruuthuse, 9 years ago

have you tried:

emmreassembly = 1

1 = enable EMM reassembly, default
There was some confusion last days on what did what.

comment:2 by dropsman, 9 years ago

@jan

If you use acamd you must set 'emmreassembly = 0' coz acamd does it itself....

comment:3 by MadMaxx, 9 years ago

right, it worked before with "0" a few days ago and after all the changes for private vars and arrays on every reader i see only skipped shared EMMs, and no EMM is written physicly to the card, nor showed up in the logfile, that an EMM is arrived for via-resders. One of the working versions for via4 and via5 was #8334 and #8459

Cryptoworks, Irdeto, Seca and Beta/Nagra looks good on shared EMMs right now.

comment:4 by gf, 9 years ago

Can you try version r8482 (the version before viaccess was converted). If it works that means the private data contains a bug. I have looked at the patch and I can't see anything that would broke your case but who knows.

Are you sure you are getting EMMs, wasn't SRG sending them for only a brief period of time during the month?

Last edited 9 years ago by gf (previous) (diff)

comment:5 by MadMaxx, 9 years ago

I tested #8482, after comparing with actual trunk there is no difference, so the problem must be somewhere else.

12 shared emms are always skipped, just 2 EMMs are really written to card.
(are the skipped emms "fakes" ?)

There are still the "EMM Update 94 00-Errors". This problem exists for Via4 and Via5. Maybe the 9400 is more like a "update not needed", so it´s not a "real" error ?

In the webinterface this 9400 card answers handled as 2 "shared emm errors"

Can someone with more knowledge with viacess4/5 SRG-cards can take a look
for the reason, why so many emms are always skipped ?

The skipping looks like "internaly". In the normal logfile no skip-infos showed up,
just the counter in the webinterface is increased to 12 skipped emms.

The used clients are ACamd/newcamd and mgcamd 1.38. Booth clients brings the same
results after a cold start of oscam.

comment:6 by gf, 9 years ago

Ignore the skipped and errors, the ones that are written is what counts.

comment:7 by Deas, 9 years ago

Resolution: fixed
Status: newclosed

no update for 3 months => closed...

Note: See TracTickets for help on using tickets.