Opened 9 years ago

Closed 9 years ago

#3259 closed defect (fixed)

Loadbalancer fogot timeout channels on card

Reported by: Micha_123 Owned by: Micha_123
Priority: critical Component: Loadbalancer
Severity: high Keywords:
Cc: Sensitive: no

Description

Revision

6789

Issue Description

It looks like the loadbalance (lb_mode=1) doesn't consider the parameter to reopen the card readers because if you put a reopen fast or after time it doesn't change anything.It seems that with a timeout the card is completely forgotten for that channel. The reader with the timeout on a channel will not reopen anymore that channel...... you can wait days ( i tested it also) and the channel will be never opened.
As soon as you clear the timeout from the statistic via webif .... et voila' the channel is opened.

When the issue occurs

if a channel is timed out

How the issue is reproducable

if the channels is reported as timeout at the statistics

Change History (6)

comment:1 by BigGyros, 9 years ago

current revision ist 8566. did you tested this on that revision?

comment:2 by Admin, 9 years ago

Isn't this just a duplicate of #2682 where you also posted?

comment:3 by superg1972, 9 years ago

I can confirm the issue. I'm obliged to delete every 1 hour the statistics otherwise I lose the card for that channels. It is a pity to have this issue since the LB is working greatly. I tried with reopened fast and after time but the result is the same. I have this issue from a long time and now I'm using 8555 version

comment:4 by malakudi, 9 years ago

Can someone describe how to reproduce the problem? Does it affect remote readers (newcamd, cccam etc) or local readers? Or both?

comment:5 by superg1972, 9 years ago

The problem it is not so easy to be reproducable. It affets both readers (remote and local).
If a channel gives a timeout (for whatever reason... i have timeouts sometimes on my TVSat card) this channel is lost, forgotten till the reset of the statistics. As soon as you reset the statistic the channel is taken in consideration again.

I test that i have done is to create a newcamd reader pointing to null an so creating timeouts. Doing this i was able to replicate it.

comment:6 by Deas, 9 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.