Opened 9 years ago

Closed 9 years ago

#3286 closed defect (worksforme)

oscam with IPV6 support not working ( not even with ipv4 )

Reported by: shapethelola Owned by:
Priority: minor Component: General
Severity: low Keywords: IPV6, reader
Cc: Sensitive: no

Description

Revision

8621

Issue Description

oscam compiled with IPv6 support not able to connect (neither IPv4 nor IPv6)

When the issue occurs

only when using a IPv6 oscam

How the issue is reproducable

When using oscam compiled with IPv6 it doesnt seem to be able to connect to the card reader server (another machine)
The important part in the log is the following I guess :

p i12 [newcamd] bind failed (errno=22 Invalid argument)

Attachments (1)

oscam.log (12.2 KB ) - added by shapethelola 9 years ago.
oscam.log

Download all attachments as: .zip

Change History (9)

by shapethelola, 9 years ago

Attachment: oscam.log added

oscam.log

comment:1 by shapethelola, 9 years ago

I was now able to verify that oscam SVN 8100 IS working. So something must have changed in that point. I have no idea tho when it stopped working

Last edited 9 years ago by shapethelola (previous) (diff)

comment:2 by Admin, 9 years ago

We are setting the outgoing IP on reader connections to the one that is set by serverip in global config (if it is set) since some revisions. So probably this is related to your problem?

comment:3 by shapethelola, 9 years ago

Ive just checked and I havent set a serverip in the configuration.

Last edited 9 years ago by shapethelola (previous) (diff)

comment:4 by shapethelola, 9 years ago

Any other idea why it doesnt work on latest oscam?

comment:5 by hapeba, 9 years ago

My opinion ... build without IPv6 and use IPv4 for all.
Otherwise, it is a never ending story ... (or use 8100 or 7518 ...)

comment:6 by manu, 9 years ago

Just verified again. It's working well here (building with IPv4 + IPv6).

However looking at your log, there's something seriously wrong with the order of these events:

30 2013/04/19 14:28:12 0 s i12 [newcamd] creating thread for device 10.0.1.9
[...]
35 2013/04/19 14:28:12 B3001000 p proxy 10.0.1.9:13337 newcamd525 (fd=0)
36 2013/04/19 14:28:12 B3001000 p i12 [newcamd] proxy initialized, server 10.0.1.9:13337
[...]
102 2013/04/19 14:28:12 B3001000 p i12 [newcamd] connecting to 10.0.1.9:13337
103 2013/04/19 14:28:12 B3001000 p i12 [newcamd] bind failed (errno=22 Invalid argument)


The correct/working order is:

2013/05/03 21:23:53 0 s raspi [newcamd] creating thread for device raspi.lan
2013/05/03 21:23:53 1362730 p proxy raspi.lan:40010 newcamd525 (fd=0)
[...]
2013/05/03 21:23:53 1362730 p raspi [newcamd] connecting to raspi.lan:40010
[...]
2013/05/03 21:23:53 1362730 p raspi [newcamd] proxy initialized, server raspi.lan:40010


which is in line with the code flow:

reader_init -> reader->ph.c_init() -> newcamd_client_init -> newcamd_connect -> connect_newcamd_server -> network_tcp_connection_open

comment:7 by shapethelola, 9 years ago

Thank you very much. This is kind of weird, yes. As I have compiled the oscam files myself I cant rule out some errors there.

I will then continue to use an old version of oscam where it is working.

Regards,

Jan

comment:8 by Deas, 9 years ago

Resolution: worksforme
Status: newclosed

not reproducible...

Note: See TracTickets for help on using tickets.