Opened 9 years ago

Closed 9 years ago

#3311 closed defect (fixed)

not found SID blocked for further use with LB enabled

Reported by: geohei Owned by:
Priority: minor Component: Loadbalancer
Severity: medium Keywords: ecm ecmpid whitelist services tntsat
Cc: Sensitive: no

Description

Revision

8639

Issue Description

WIKI says that services are treated as whitelists if LB is enabled.


Services sind für den Loadbalancer eine Whitelist. Das bedeutet, dass alles, was hier eingetragen wird, vom Loadbalancing als Service behandelt wird, den die Karte kann! Wenn dann z.B. ein "not found" kommt, wird das ignoriert und die Karte wird weiter angefragt, mit dem damit verbundenen traffic!


This would mean that a "not found" SID is ignored and the card is continued to be queried with the same (non working) SID.

This is useful in 2 situations.

  1. PPV, which opens a channel only temporarily.
  1. Multiple CaID:Provider ID combinations, but with different ECMPID (example TF1 SID 0x2206 on 19.2e, 0500:030b00). In this example, the first ECMPID doesn't work (0x43e) but the second works (0x443). Even if SID 0x2206 is defined as positive service, the first ECMPID (which is not working) sends the SID to the "not found" list and the seconds ECM with ECMPID 0x443 doesn't reach the card anymore.

See these threads.
http://www.streamboard.tv/wbb2/thread.php?threadid=37878 (mainly pages 2 & 3)
http://www.streamboard.tv/wbb2/thread.php?threadid=38113

When the issue occurs

Always

How the issue is reproducable

With ECM requests from SIDs to a card which doesn't have these SIDs

Change History (2)

comment:1 by geohei, 9 years ago

Keywords: tntsat added

comment:2 by Deas, 9 years ago

Resolution: fixed
Status: newclosed

we don´t need a ticket when there is work in progress: http://www.streamboard.tv/wbb2/thread.php?threadid=37989

Note: See TracTickets for help on using tickets.