Opened 9 years ago

Closed 9 years ago

#3319 closed defect (fixed)

specific reader no longer used as soon as data for lb is collected

Reported by: sirdir Owned by:
Priority: major Component: Loadbalancer
Severity: high Keywords: lb
Cc: Sensitive: no

Description

Revision

r8642

Issue Description

a reader connected via cmad35 is working fine as long as lb_stats are collected, as soon as the configured 5 samples are collected the reader is not used anymore. But even readers which have the according services blocked get queried.

When the issue occurs

after 5 ecms

How the issue is reproducable

after each restart, 5 ecms get read, then 'no matching group'.

Attachments (1)

oscam.log.orf.error (280.8 KB ) - added by sirdir 9 years ago.
log

Download all attachments as: .zip

Change History (8)

by sirdir, 9 years ago

Attachment: oscam.log.orf.error added

log

comment:1 by sirdir, 9 years ago

by the way: as soon as the statistics of the reader are reset, it starts working again for 5 ecms...

comment:2 by sirdir, 9 years ago

... reverted back to 8633 everything is working as expected there.

comment:3 by homesite, 9 years ago

Last working Version is #8639.
After this Revision the same problem as sirdir wrote.

After the lb_min_ecmcount i got rejected group.
Resetting the statistics and it works as long as lb_min_ecmcount is reached.

Last edited 9 years ago by homesite (previous) (diff)

comment:4 by homesite, 9 years ago

Solution:

Set the lb_weight lower than 100 and it works again.

I think it's because the cw's/keys are to fast (about 1-2sec) from the camd3 emu or whatever to be recognized by the loadbalancer....

in reply to:  4 comment:5 by sirdir, 9 years ago

Replying to homesite:

Solution:

Set the lb_weight lower than 100 and it works again.

I think it's because the cw's/keys are to fast (about 1-2sec) from the camd3 emu or whatever to be recognized by the loadbalancer....

Yes, that helps. Still a bug, isn't it?

comment:6 by blueven, 9 years ago

Try lbfix6.patch in ticket #2682

comment:7 by Deas, 9 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.