Opened 9 years ago

Closed 7 years ago

#3552 closed defect (fixed)

reader-nagra.c: array out of bounds

Reported by: Philipp Owned by:
Priority: major Component: Reader
Severity: high Keywords:
Cc: Sensitive: no

Description

Revision

9131

Issue Description

global.h

uchar ecmcommandcache[4]; cachebuff for ecm commands

reader-nagra.c: In function 'nagra2_do_ecm':
reader-nagra.c:1097:33: warning: array subscript is above array bounds [-Warray-bounds]
       if(reader->ecmcommandcache[t] == er->ecm[3]) { matchfound++; }
                                 ^

Someone should fix that ;)

When the issue occurs

newer compiler with EXTRA_CC_OPTS="-O3 -fuse-linker-plugin"

How the issue is reproducable

<Please fill in>

<Don't forget to ATTACH (NOT post here as text) a log file of oscam in debug mode (start oscam with -d255) and to remove the brackets around the fields! Otherwise, your ticket will be closed as you seem to be unable to read.>

Change History (2)

comment:1 by gf, 9 years ago

ecmcommandcache must be increased to [5]

comment:2 by gf, 7 years ago

Resolution: fixed
Status: newclosed

Fixed in r9780.

Note: See TracTickets for help on using tickets.