Opened 11 years ago

Closed 11 years ago

#36 closed defect (invalid)

SMARGO reader doesn't work

Reported by: boubaris Owned by:
Priority: major Component:
Severity: medium Keywords:
Cc: Sensitive: no

Description

I run OSCAM 0.99.4.465 (recompiled by me from SVN) in a small i386 Linux box (Ubuntu 8.04 server 32bit).
I've connected to my Linux box two readers: a simple serial Phoenix (/dev/ttyS0) and a SMARGO USB cardreader (/dev/ttyUSB0)

I've a Viaccess card CAID 0500

The serial reader works fine and this is the log


2009/10/22 22:17:39   9929 s   reader started (pid=9933, device=/dev/ttyS0, detect=none, mhz=357)
2009/10/22 22:17:39   9929 s   anti cascading disabled
2009/10/22 22:17:41   9933 r02 card detected
2009/10/22 22:17:44   9933 r02 ATR: 3F 77 18 00 00 C2 47 40 00 68 90 00 
2009/10/22 22:17:46   9933 r02 type: viaccess(standard atr), caid: 0500, serial: 319xxxx170
2009/10/22 22:17:46   9933 r02 providers: 3 (FFF830,024400,024410)
2009/10/22 22:17:46   9933 r02 ready for requests
2009/10/22 22:17:46   9933 r02 card detected
2009/10/22 22:17:46   9933 r02 serial: 319xxxx170
2009/10/22 22:17:47   9933 r02 provider: 1, id: FFF830, sa: BE26129A, geo: empty
2009/10/22 22:17:47   9933 r02 provider: 2, id: 024400, sa: BE26129A, geo: FF FF FF FF 
2009/10/22 22:17:47   9933 r02 class: DC, expiry date: 2009/08/29 - 2010/08/28
2009/10/22 22:17:48   9933 r02 provider: 3, id: 024410, sa: BE26129A, geo: FF FF FF FF 

This is my oscam.server configuration:

[reader]
Label          = PhoenixReader
Protocol       = mouse
Detect         = none
Device         = /dev/ttyS0
Fallback       = 0
Group          = 1
EMMCache       = 1,1,2

I put my Viaccess card in SMARGO but it doesn't work:

2009/10/23  7:20:47  10615 s   reader started (pid=10619, device=/dev/ttyUSB0, detect=none, mhz=357)
2009/10/23  7:20:47  10615 s   anti cascading disabled
2009/10/23  7:20:50  10619 r02 card detected
2009/10/23  7:20:55  10619 r02 ATR: 3F 77 18 00 00 C2 3F 77 18 00 00 C2
2009/10/23  7:20:56  10619 r02 card system not supported
2009/10/23  7:20:56  10619 r02 card initializing error
2009/10/23  7:21:22  10615 s   cardserver down

As you can see , ATR is truncated and then the first half [3F 77 18 00 00 C2] is duplicated.

My oscam.server about SMARGO:

[reader]
Label          = SmargoReader
Protocol       = smartreader
Detect          = none
Device         = /dev/ttyUSB0
Fallback       = 0
Group          = 1
EMMCache       = 1,1,2

I attach here a small documentation about tcsetattr(). I hope to help you

Attachments (1)

Smartreader_integraters_manual.txt (2.1 KB ) - added by boubaris 11 years ago.
SMARGO low level C interface

Download all attachments as: .zip

Change History (5)

by boubaris, 11 years ago

SMARGO low level C interface

comment:1 by boubaris, 11 years ago

Accordingly to Smartreader_integraters_manual.txt


After entering CMD mode and returning to DATA mode the reader is configured as Smartreader+ and will probably not work as a phoenix till the next time it's cold started by removing the device from the USB port.


I've tried to disconnect and reconnect my Smargo from USB port. Now it should works as a simple Phoenix reader but the problem is exactly the same.

BTW: Usually I run CCcam 2.1.x in my Linux server without any problem (protocol smartreader+, 6.00 Mhz)

comment:2 by boubaris, 11 years ago

MMhhh I've read just now this ticket
http://www.streamboard.tv:8001/oscam/ticket/14

If you see its ATR is equal to mine (with Smargo): the first half is duplicated ....

comment:3 by rorothetroll, 11 years ago

I made a lot of change for the smargo reader in the merlin branch so you might want to give it a try.
I won't backport these change to the main trunk as the code structure is going to change a lot in the merlin branch and it will become the trunk at some point.

R.

comment:4 by landlord, 11 years ago

Resolution: invalid
Status: newclosed

It's not a problem of oscam. It's a problem of some smargo readers.

Note: See TracTickets for help on using tickets.