Opened 6 years ago

Last modified 5 years ago

#4097 reopened defect

OSCam r10403 crashes after restart by webif

Reported by: horizon1 Owned by:
Priority: Please fill in Component: Webinterface
Severity: Please fill in Keywords:
Cc: Sensitive: no

Description

Hello,
Problem with OSCam r10403.
When I try to restart by webif, oscam crashes, 50% of the trials. Tested receiver ET6000 and PC 64 bits with Ubuntu OS

Change History (11)

comment:1 by psg, 6 years ago

same for me on dm500, it's ram clear issue. if ram cleared after restart (webIF or button rstart) oscam working sometimes it not clear ram then crash

comment:2 by AbrahaM, 6 years ago

Please test r10402 and r10401 too. That would be helpfull for developers. I suspect result, but I don't want to suggest anything.

comment:3 by ultra47, 6 years ago

Please try r10406

comment:4 by horizon1, 6 years ago

Last test was made with version 10412. The problem is still present.

comment:5 by stefansat sat, 6 years ago

small note if restart out off web if normaly the buffers should be cleared And the ram avbl again.

After killall -9 oscam, they are not. That's perhaps something which could be enhanced in future having an extra oscam -stop command which clears all buffers and make the used ram avbl again.

This last one is especially a problem on for example dm8000. I use a hackis work around in oscam start stop script by using:

after the killall line adding
sync; echo 3 > /proc/sys/vm/drop_caches

Then I do never have problems.However I think the main issue is fragmentation of mem. By using that sync fragmentation is gone.

Using a swap file is also a good thing to avoid crash. Set this on internal hdd or You can also use an usb stick (note) if swap to frequentely used the lifetime of usb stick will be pretty short.

comment:6 by gf, 6 years ago

Don't use such hacks as dropping caches. You don't need to care about OS "buffers", the memory should be used not stay free and the kernel knows how to use efficiently by keeping "buffers" which are just cahched files. If memory is needed the kernel releases it.

comment:7 by stefansat sat, 6 years ago

Yes I know. But since the kernels used on oe-2.0 or higher by dm8000 You have to do that. And by vuduo2 also. and the vuduo2 has 1gb of ram.

When I do, this never a problem whitout after a couple of stops and restart off oscam big shit. By dm8000 about 4 to 5 by vuduo2 about 20 .

Same goes up after dvd iso files are played that hack needs to be run. And also this was not needed with lower version kernels.

Why ? I don't but a suspect a mem fragmentation problem on mips introduced by the higher kernels.

comment:8 by Aeon, 5 years ago

I have recently fixed some restart bugs.
Is it better now?

comment:9 by Aeon3, 5 years ago

Resolution: fixed
Status: newclosed

I made some tests and it seems to work now.
If there are still problem, please post a log with the hightest loglevel/debuglevel.

comment:10 by Aeon3, 5 years ago

Resolution: fixed
Status: closedreopened

comment:11 by savan, 5 years ago

Problem is happen when oscam.server is modified manualy trough "files" web menu, in all situations restarting oscam trought webinterface crashed oscam!

Last edited 5 years ago by savan (previous) (diff)
Note: See TracTickets for help on using tickets.