Opened 6 years ago

Last modified 5 years ago

#4109 reopened defect

oscam.emmcache is not found at startup if an emm log dir is set

Reported by: Mandos Owned by: theparasol
Priority: minor Component: General
Severity: low Keywords: emm cache
Cc: Sensitive: no

Description

Revision

r10420 to r10441

Issue Description

If an emm log dir is configured, oscam.emmcache is saved in the oscam config directory; if not, it goes to /tmp/.oscam/. However, the function emm_load_cache that loads the file at startup only looks in /tmp/.oscam.

When the issue occurs

If an emm log dir is configured.

How the issue is reproducable

Set up an emm log dir, wait for some EMMs, restart OSCam.

As only one log line is required to show the issue, I can see no reason to attach a log file:

2015/02/07 19:00:37 0 s (emmcache) can't read emmcache from file /tmp/.oscam/oscam.emmcache

Change History (4)

comment:1 by AbrahaM, 6 years ago

Owner: set to theparasol

comment:2 by Mandos, 6 years ago

Resolution: fixed
Status: newclosed

fixed in r10442. Thx theparasol.

comment:3 by geohei, 5 years ago

Resolution: fixed
Status: closedreopened

Sorry, not fixed.
Found this ticket only after posing mine.
Sorry!
http://www.streamboard.tv/oscam/ticket/4390

comment:4 by Opti, 5 years ago

SVN 11203 = OK
2015/12/30 19:53:57 00000000 s (main) init for all local cards done
2015/12/30 19:53:57 00000000 s (emmcache) loaded 5483 emmcache records from /etc/tuxbox/config/oscam/oscam.emmcache in 85 ms
2015/12/30 19:53:57 00000000 s (emmcache) loaded 0 emmstat records from /etc/tuxbox/config/oscam/oscam.emmstat in 0 ms

Note: See TracTickets for help on using tickets.