Opened 6 years ago

Last modified 5 years ago

#4253 reopened defect

Higher CPU Load - problem with EMM Cache

Reported by: sd88ds Owned by:
Priority: major Component: General
Severity: high Keywords:
Cc: Sensitive: no

Description

CPU Load is much higher as before Changeset 10875

Change History (7)

comment:1 by Aeon, 6 years ago

Resolution: worksforme
Status: newclosed

this change only affected dre-readers and scam-protocol.
if you are using any of those two, please re-open this ticket.

comment:2 by tommys, 6 years ago

Resolution: worksforme
Status: closedreopened

yes..I am using newcamd and load is much higher.

comment:3 by Aeon, 6 years ago

newcamd is still using the old des code.
did you even read my post?

this change only affected dre-readers and scam-protocol. <<

comment:4 by zipiju, 6 years ago

I can confirm much higher CPU load on x64 on revisions beyond 10419 (r10419 CPU load <= 2%; r10420 up to at least 11211 CPU load ~140%/SMP). There is also some instability tied to this higher CPU load - OSCAM/newcamd stops sending ECMs and are only sending EMMs to the reader after random period of time (might be days, might be an hour).
Using newcamd as a protocol, one smargo reader with one Irdeto card in CW fallback.
Compiled on GCC 4.9.3.

Last edited 6 years ago by zipiju (previous) (diff)

comment:5 by zipiju, 6 years ago

Severity: lowmedium

comment:6 by zipiju, 5 years ago

The higher load is caused by EMM cache not working correctly (at least for Irdero in CW fallback and Irdeto), causing what seems like a memory leak and higher and higher CPU load as cache contains more and more records. This leads to a state in which ECM response times are very high, even causing timeouts. Further it would probably cause a crash of OSCam due to exhausted memory. The changeset in r10420 changed the way how EMM buffer is handled. Since that rev. there is a problem with EMM cache at least for the two systems above. Since r11054 (at least to current r11293) EMM cache is disabled in code for Irdeto due to the problem described above. This disable doesn't work for Irdeto in CW fallback, so to avoid this problem one needs to disable EMM cache for the particular reader in reader seetings.
Maybe someone should take a look at the buffer code in oscam-emm-cache.c and should maybe revert it back to the ring buffer as before the r10420.

comment:7 by zipiju, 5 years ago

Component: ! Please select...General
Priority: Please fill inmajor
Severity: mediumhigh
Summary: Higher LoadHigher CPU Load - problem with EMM Cache
Note: See TracTickets for help on using tickets.