Opened 8 years ago

Closed 4 years ago

#4261 closed defect (fixed)

"ECM Doublecheck" is broken - not working properly

Reported by: tunder8181 Owned by: theparasol
Priority: major Component: Loadbalancer
Severity: high Keywords: ECM Doublecheck, loadbalancer
Cc: Sensitive: no




Issue Description

"ECM Doublecheck" feature is not working properly. ECMs are being sent to both readers, but Oscam picks the fastest CW end sends it back to the client. Instead of first comparing the CW's and only after that return the CW to the client.

I have in my settings:
double_check = 1
lb_nbest_readers = 2

When the issue occurs

When one of the readers crashed, the other one continued to work normally and return CWs to the client. I would expect Oscam not to return any CWs since it cant compare them to the other reader.
I also tested the the other scenario. Two working readers. One with real card and second virtual reader with fake CW's.
ECMs were forwarded to both readers, but Oscam picked the fastest reader and sent back the CW to the client, without waiting for second CW to compare between them. I would expect Oscam in this case not to return any CW since they were different -one real and second one fake.
So in both cases, when one reader crashed and when one reader gave fake CWs, Oscam failed and continued providing CWs to the client.

How the issue is reproducable

Just do the same like me. Crash one of the readers or create another reader with different CWs.

Change History (5)

comment:1 by Aeon, 8 years ago

Please post a log.
It should contain some lines containing "DOUBLE CHECK".

comment:2 by tunder8181, 8 years ago

When both readers are active, it shows "DOUBLE CHECK". But when one crashes, it continues to work normally and "DOUBLE CHECK" ends on one reader only.
I will try to reproduce and attach the log.

comment:3 by Jannyy, 5 years ago

This bug is almost completely solved here:

Thanks to Bust3D for bug fix and Optimum Power for patch file.

comment:4 by Jannyy, 5 years ago

Owner: set to theparasol

comment:5 by Opti, 4 years ago

Resolution: fixed
Status: newclosed

This bug is almost completely solved here: ​

Note: See TracTickets for help on using tickets.