Opened 6 years ago

Last modified 6 years ago

#4267 new defect

c (newcamd) AU disabled for user using newcamd port config 9999@0000:000000

Reported by: davequattro Owned by:
Priority: minor Component: Protocol - Newcamd
Severity: medium Keywords: AU
Cc: Sensitive: no

Description

Revision

<10899>

Issue Description

I updated oscam from version 10108 to 10656 and also to last 10899

With version 10108 i can update my cards with MGcamd or with oscam with newcamd protocol.
But with version 10656 or 10899 i can't, but when i use proxy reader with an other oscam i can update.

So when i use 10108 or proxyreader with later versions i get the message:

2015/07/22 20:02:43 8BCD810 c (newcamd) client connected to 9999 port
2015/07/22 20:02:43 8BCD810 c (client) encrypted newcamd:9999-client 192.168.1.5 granted (living, au=on (1 reader))
2015/07/22 20:02:43 8BCD810 c (newcamd) user living authenticated successfully (mgcamd)
2015/07/22 20:02:43 8BCD810 c (newcamd) AU enabled for user living on reader oscamNewcamd
2015/07/22 20:02:43 8BCD810 c (newcamd) SID list will not be send to mgcamd client.

When i use later versions from oscam and want direct update to the cards, i get the massage:

2015/07/22 20:04:19 8BCC3D0 c (newcamd) client connected to 9999 port
2015/07/22 20:04:19 8BCC3D0 c (client) encrypted newcamd:9999-client 192.168.1.5 granted (living, au=on (1 reader))
2015/07/22 20:04:19 8BCC3D0 c (newcamd) user living authenticated successfully (mgcamd)
2015/07/22 20:04:19 8BCC3D0 c (newcamd) AU disabled for user living
2015/07/22 20:04:19 8BCC3D0 c (newcamd) SID list will not be send to mgcamd client.

I found the problem...

I have used for years in the newcamd port config 9999@0000:000000 and use services so that i not have to use multiple ports

When i put this 9999@0100:00006A in the newcamd port config the user is to be able the cards to update, then i get the massage c (newcamd) AU enabled for user living on reader oscamNewcamd again.

I don't know who has changed this in the oscam build, but it would be nice, if its possible to change this back so that i don't have to open multiple ports and that i can update my cards

In version 10108 works it without problems with the newcamd port config like this 9999@0000:000000 and i'm able to update the cards

Change History (7)

comment:1 by Aeon, 6 years ago

please try r10901

comment:2 by davequattro, 6 years ago

Thank you, fix works, i get message again c (newcamd) AU enabled for user living

comment:3 by davequattro, 6 years ago

When i look at the mgstat.info MGcamd sends EMM's, but there is nothing happening in oscam.
In oscam version 10108 i had in 1 minute the updates

Mgcamd v1.38 by mixvt, patched by D2MAC on Oct 23 2011, Fri Jul 24 16:29:14 2015
mg uptime 00d 00h 08m 08s, service changes: 1, ecm processed: 50, lost cw warnings: 0

Newcamd:

Host/port Recon. Emm out Ecm out Cw in Avg. ecm time

192.168.1.4 : 9999 2 2 81 80 329
192.168.1.4 : 9999 1 2 0 0 0
192.168.1.4 : 9999 1 2 0 0 0
192.168.1.4 : 9999 1 2 0 0 0
192.168.1.4 : 9999 1 2 0 0 0

Last edited 6 years ago by davequattro (previous) (diff)

comment:4 by davequattro, 6 years ago

I have tried http://www.streamboard.tv/oscam/changeset/10913 but oscam crashes when i login with MGcamd, with oscam newcamd protocol no crash problem

comment:5 by Aeon, 6 years ago

please try r10917

Last edited 6 years ago by Aeon (previous) (diff)

comment:6 by davequattro, 6 years ago

I have tested 10917, but that was not working, now i use 10937 but with setting 9999@0000:000000 nothing happend, when i change this into 9999@0100:000000 the update starts directly with MGcamd.

Still, in version 10108 MGcamd updates with the setting 9999@0000:000000

comment:7 by davequattro, 6 years ago

Nobody?

Note: See TracTickets for help on using tickets.