Opened 6 years ago

Last modified 6 years ago

#4286 new defect

gbox protocol broken

Reported by: chimpie23 Owned by:
Priority: major Component: General
Severity: medium Keywords: gbox
Cc: Sensitive: no

Description

Revision

10943

Issue Description

gbox protocol does not work anymore. It fails when it tries to send hello messages with the following message in the log:
Invalid call to gbox_send_hello with peer
Revision 10648 works flawlessly.

When the issue occurs

everytime gbox wants to exchange hello messages

How the issue is reproducable

compile with gbox support. Try to use it with another gbox.

<Don't forget to ATTACH (NOT post here as text) a log file of oscam in debug mode (start oscam with -d255) and to remove the brackets around the fields! Otherwise, your ticket will be closed as you seem to be unable to read.>

Change History (2)

comment:1 by disisdavo, 6 years ago

just looking at this, my gut feel is to try compile 10853 if works try 10854 this maybe where it got broke. there has only been about 11 changes to the module-gbox.c file between your last working and trunk, best to compile each version and test one at a time to narrow down for the developers where it breaks, hope this helps a little, I think sometimes we owe it to ourselves to do a little research.

10870, 10859, 10857, 10854<--my guess where problem may start, 10818, 10817, 10813, 10781, 10749, 10694, 10650 10648<-- your last working version.

davo

comment:2 by Aeon, 6 years ago

Your guess is wrong.
Please post a log file with all debug levels.

Last edited 6 years ago by Aeon (previous) (diff)
Note: See TracTickets for help on using tickets.