Opened 5 years ago

Last modified 5 years ago

#4411 new defect

[smargo] card system not supported

Reported by: B.A. Derks Owned by:
Priority: critical Component: Reader
Severity: high Keywords: smargo initialization checksum
Cc: Sensitive: no



11209 (CYGWIN_NT-6.2-WOW64 under Windows 10 with SmartReader V2)

Issue Description

[smargo] card system not supported

When the issue occurs

at start up oscam initially or via webif

How the issue is reproducable

start up oscam

A couple of days ago I switched to oscam-11209 and used it under Linux and Windows 10 (with CYGWIN) in combination with a SmartReader V2 usb card reader. Under Linux I use the smartreader protocol with the device SRv2;Serial:... Under Windows I use the smargo reader with device /dev/ttyS3. All went well, no problems what so ever and it looked extremely stable. Al least far more stable then the mouse protocol I used up to that moment. However, after I added some hard drives to my PC yesterday, there is no way I get oscam up and running again with the smargo card reader. I even reverted back to a older version of the FTDI driver. But from the log file I do not get the impressing there is a driver problem.
Examining the oscam log I notice 3 errors. One error reading a data block of 33 bytes and two checksum errors. Especially the first checksum error looks fatal (log line 309). It is not clear to me what data is checksummed so it is hard to figure out whether or not this checksum error is correct.
I have noticed that this smargo problem of 'card system not supported', is a very old problem and that there is even a dirty hack for it in reader-irdeto.c. However, the problem here looks to be a different problem, especially as oscam started and worked flawlessly with the smargo protocol for a couple of days.

Keep up your great work,

Attachments (2)

oscam - smargo startup.log (92.5 KB ) - added by B.A. Derks 5 years ago.
oscam - smargo startup success.log (238.7 KB ) - added by B.A. Derks 5 years ago.

Download all attachments as: .zip

Change History (3)

by B.A. Derks, 5 years ago

Attachment: oscam - smargo startup.log added

comment:1 by B.A. Derks, 5 years ago

Today oscam in combination with the SmartReader v2 USB card reader, started without problems and it worked flawlessly afterwards. That happened after I first used oscam under linux testing a new build of tvheadend. After a reboot into Windows 10, oscam started just fine and I was able to restart oscam a couple of times via the webIF without any problems. On one of these restarts I produced a log with the same debug settings as the log I posted before (oscam - smargo startup.log) of the failed startup of oscam.
Comparing both logs shows that the first 168 lines are identical. At that point the failed log shows 3 lines of bytes read. Then both logs are identical again up to line 242, including the same error message at line 229. From line 243 onwards, the logs diverge more and more. I hope these 2 log files are helpfull for solving the failing startup of oscam with the SmarReader v2 USB card reader in combination with the smargo protocol.

Last edited 5 years ago by B.A. Derks (previous) (diff)

by B.A. Derks, 5 years ago

Note: See TracTickets for help on using tickets.