Opened 7 years ago

Closed 7 years ago

#4436 closed defect (fixed)

Audio stream type 0x06 not decoded

Reported by: Frank Gallagher Owned by:
Priority: minor Component: DVBApi
Severity: medium Keywords: oscam-emu powervu audio
Cc: Sensitive: no

Description

Revision

11086

Issue Description

In r11086, audio stream type 0x06 was no longer detected as an audio stream, however 0x06 is used as the audio stream type for the channels located on Thor6 12303V. Thus in r11085 audio works (albeit only the first audio stream), but in r11086 no audio is decrypted.

When the issue occurs

When tuned to a channel on Thor6 12303V, e.g. ID Xtra, being decrypted with oscam-emu in non-stream-relay mode, i.e. passing the stream back through dvbapi (vdr used to display the stream).

How the issue is reproducable

Apply an oscam-emu patch relevant to the oscam svn version being used to allow decryption of powervu channels & configure appropriately.

Disable stream-relay - OSCam Config -> Stream Relay -> Mode = disabled (use DVBAPI)

Enabled extended CWs - OSCam Config -> DVB-Api -> APU for extended CWs = 1 - OE2.2

Install the latest vdr-dvbapi plugin from git (vdr-dvbapi release 2.2.2 doesn't work with CW extended 2.2)

Set VDR to tune to a channel on Thro6 12303V

I can't see anything obviously different comparing the -d255 log of the non-working audio with the log from adding 0x06 to the list of audio stream IDs, but that does seem to be the solution to get audio out. I got the idea for adding back 0x06 from
https://github.com/joeusercz/OSEmu/commit/b75258442f14f19b0234e79775b9d697c1c3705e
Which I guess fixes the same issue when stream_relay is enabled.

However, even this fix only enables the first audio stream to be decrypted. I've found a workaround to enable all audio streams, but I'll make a new ticket for that.

Attachments (1)

oscam.log (97.1 KB ) - added by Frank Gallagher 7 years ago.
-d 255 log file

Download all attachments as: .zip

Change History (2)

by Frank Gallagher, 7 years ago

Attachment: oscam.log added

-d 255 log file

comment:1 by ni hao, 7 years ago

Resolution: fixed
Status: newclosed

Should be fixed with r11213

Note: See TracTickets for help on using tickets.