Opened 6 years ago

Last modified 6 years ago

#4484 new defect

bug OScam Webif with svn-r11270 x86_64-linux-gnu

Reported by: lotus Owned by:
Priority: major Component: Webinterface
Severity: high Keywords: bug, webif, restarts
Cc: Sensitive: no

Description

Revision

oscam-1.20-unstable_svn-r11270

Issue Description

OScam Server installed running now for 1 week with Gbox, CCcam and Camd connection. When (only) Gbox peers connected OScam Webif restarts < 1minute. oscam-svn keeps working. When only use emu: CCcam and Camd, then all works fine. Webif dont restarts. When connecting Gbox peers then Webif restarts continue within 1 minute.

1) Hereby the full description & test results with peers;
config: Ubuntu 16.04 Oscam svn-r11270 Server contains:
21 Gbox peers – 18 CCcam/Oscam peers, 2 (home) camd peers.

The OScam Server give a false response about "unknown", "offline", back "online" status. but the connection has nothing to do with these false messages. Tested with CCcam / OScam peers. The connection is stable, no freezes on channels, no hang up, there is absolute nothing wrong with the connection from/to the server. At this moment it looks that the cause of the false message's come because of the active emu's [CCcam, Camd, and gbox]. All lines -reader- and -user- settings are already proper configured:


2) Connected emu: Only CCcam & Camd then all works fine, also confirmed by other CCcam/OScam peers:

response from cccam peer:
At this moment I have only this log: saxxxx_xxxxx_CCcam [CCcam] connecting to xxxxx.no-ip.biz:xxxx. This message is displayed for an average of every 20 seconds. none info about disconnect.


3) response from me:
Connected emu: CCcam - Camd
I find out that the OScam Webif generate a false response about "unknown", "offline", back "online" status. If only CCcam connect, then at this moment the OScam Webif is online for 1 hour, 14 minutes and 14 seconds. root OFF 127.0.0.1 0 server 0000:0000@000000 01:14:14 OK

Normally when all emu's connected (CCcam, Camd and Gbox), then the OScam Webif restarts after +/- 1 minute back to 00:00:00. The OScam Server service, dont stop, and is running (that is important!). But the peers get every time the false response about "unknown", "offline", back "online" status when the OScam Webif restart. I can reproduce the problem.


4) Connected emu in OScam.conf: CCcam – Camd – Gbox. No gbox peers connection in user / reader. The OScam Webif works good.


5) When Gbox peers user / reader connected, then OScam Webif restarts all the times < 30 seconds. Sharing Gbox with Gbox and CCcam with CCcamp then OScam Webif restarts all the times.


6) Connected emu: Gbox - Camd
Only Gbox peers connected then OScam Webif restarts all the times < 30 seconds.


Point 5 and point 6 makes the problem clear. When Gbox peers involved, then Webif restarts all the time. Peers get a false notification about the connection.

When the issue occurs

When (only) Gbox peers configured

How the issue is reproducable

By using Gbox udp protocol ins oscam.conf and connect Gbox peers in oscam.user and oscam.server.

<Don't forget to ATTACH (NOT post here as text) a log file of oscam in debug mode (start oscam with -d255) and to remove the brackets around the fields! Otherwise, your ticket will be closed as you seem to be unable to read.>

ATTACH?: when i start oscam in debug mode: [root@ubuntu:/usr/bin# oscam-svn -d255 start] then oscam-svn starts for about 1 minute, but i dont see any output on screen / or on file???.... after 1 minute i get my prompt back and oscam-svn is not running anymore....

Attachments (1)

oscam.log (185.0 KB ) - added by lotus 6 years ago.
oscam.log

Download all attachments as: .zip

Change History (4)

by lotus, 6 years ago

Attachment: oscam.log added

oscam.log

comment:1 by lotus, 6 years ago

OSCam Webinterface developed by Streamboard Team
Current Time: 17.07.16 | 21:14:55 Start Time: 17.07.16 | 21:08:45 OSCam Run Time: 00:00:09
Process ID: 17637 Access from: 192.168.1.47 Run as: root System Up Time: 14d 02:20:21
OSCam: 1.20-unstable_svn Build: r0 Compiler: x86_64-linux-gnu
WebIf Style by Streamboard Team

More info:
[OSCam Run Time:] restarts every +/- < 60 seconds when Gbox peers connected.
Process ID: 17637 continue - stay alive.

comment:2 by lotus, 6 years ago

one more:

OSCam Webinterface developed by Streamboard Team
Current Time: 17.07.16 | 21:24:16 Start Time: 17.07.16 | 21:16:21 OSCam Run Time: 00:00:22
Process ID: 17637 Access from: 192.168.1.47 Run as: root System Up Time: 14d 02:29:42
OSCam: 1.20-unstable_svn Build: r0 Compiler: x86_64-linux-gnu
WebIf Style by Streamboard Team

comment:3 by lotus, 6 years ago

last log for today. Hope the Streamboard Team can solve this problem. Thx in advance!

OSCam Webinterface developed by Streamboard Team
Current Time: 17.07.16 | 21:50:42 Start Time: 17.07.16 | 21:16:21 OSCam Run Time: 00:00:20
Process ID: 17637 Access from: 192.168.1.47 Run as: root System Up Time: 14d 02:56:08
OSCam: 1.20-unstable_svn Build: r0 Compiler: x86_64-linux-gnu
WebIf Style by Streamboard Team

Note: See TracTickets for help on using tickets.