Opened 5 years ago

Closed 4 years ago

#4490 closed defect (fixed)

no "prefer local cards" in global config section

Reported by: AbrahaM Owned by:
Priority: minor Component: Webinterface
Severity: medium Keywords: webif prefer local cards
Cc: Sensitive: no

Description

Revision

<11272>

Issue Description

There is no "prefer local cards" in global config section

When the issue occurs

always

How the issue is reproducable

when oscam is compiled without any "reader" support

"Recently" to the reader was added parameter "local cards", which is allowing for intepreatation of reader as "local" (I'm not explaining how that function works). But unfortunetly after that change trunk/webif/pages_index.txt was not changed accordingly.

result: It's impossible to see/set "prefer local cards" in webif when there is no support of any "readers"

solution/fix: In line 61 "WITH_CARDREADER" needs to be removed. Patch is attached.

Attachments (2)

preferlocalcardsfix.patch (890 bytes ) - added by AbrahaM 5 years ago.
ticket-4490.patch (1.7 KB ) - added by pr2 4 years ago.
Proper implementation of this request.

Download all attachments as: .zip

Change History (9)

by AbrahaM, 5 years ago

Attachment: preferlocalcardsfix.patch added

comment:1 by pr2, 5 years ago

But if you have no local card reader compiled into your OScam why would you have to see this parameter since it only applies to local physical reader?
So no physical reader no "prefer local reader" this is logic.

comment:2 by theparasol, 5 years ago

If I remember correctly some time ago someone changed the behavior of preferlocalcards.
Some users have "local cards" but they are sitting in an another receiver or server in their house. So preferelocalcards is a bit misused to mark certain proxy readers as local.

comment:3 by AbrahaM, 5 years ago

Yes, you are right, that there is no local reader support compiled and that is reason of absence of that option.

Maybe I'm wrong, but in my opinion after "recent" changeset/commit that introduced parameter "local cards" for proxies (between "class" and "AU disabled" , "preferlocalcards" started to be again usefull option for proxies too, so restriction only for "physical" readers should be lifted.

Presence of "preferlocalcards" would allow more possibilites to balance proxies and cacheex. I think it will still possible by direct definitions in oscam.config, but without visibility and control in webif.

Last edited 5 years ago by AbrahaM (previous) (diff)

comment:4 by pr2, 5 years ago

I was not aware of this change, which I think is totally useless, since LB is active we just need to properly configure the weight and we can achieve exactly the same result.

Anyway I update the wiki in en and fr to support this localcards parameter based on this description:

http://www.streamboard.tv/oscam/ticket/4127

by pr2, 4 years ago

Attachment: ticket-4490.patch added

Proper implementation of this request.

comment:5 by pr2, 4 years ago

Please test this patch.

Your patch works but also include two other parameters that are really linked with physical readers, so mine only move prefer local card parameter into global section.

comment:6 by AbrahaM, 4 years ago

Confirmed, working as intended. Yours patch is better / correct one.

comment:7 by Gorgone Impertinence, 4 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.