Opened 5 years ago

Closed 5 years ago

#4630 closed defect (fixed)

Frustrating text errors WIKI page Building Oscam

Reported by: B.A. Derks Owned by:
Priority: Please fill in Component: ! Please select...
Severity: Please fill in Keywords:
Cc: Sensitive: no

Description

 Now to build OSCAM with libusb support you need the following commands:

make USE_LIBUSB=1

# To build OSCAM with static libusb you have to change LIB_LIBUSB variable to point to the static library
make USE_LIBUSB=1 LIB_USBLIB=/usr/local/lib/libusb-1.0.a

# Since OS X is kind of special to build with static libusb you have to use the following command
make USE_LIBUSB=1 LIBUSB_LIB="/usr/local/lib/libusb-1.0.a -lobjc -framework IOKit -framework CoreFoundation"


In these few lines three different symbolnames are used to give the location of libusb. LIBUSB_LIB is the only one that works.
Thanks for all the great work you are doing to make my TV server working like charm.

Baderks

Change History (1)

comment:1 by Don de Deckelwech, 5 years ago

Resolution: fixed
Status: newclosed

Hi,
fixed. But you could have done it yourself (like me, it took me just a couple of minutes), it's a WIKI, for heavens sake... ;)
DdD.

Note: See TracTickets for help on using tickets.