Opened 5 months ago

Last modified 4 months ago

#4804 reopened defect

Backdoor or error ?

Reported by: Unique Owned by:
Priority: Please fill in Component: ! Please select...
Severity: Please fill in Keywords:
Cc: Sensitive: no

Description

Revision

from 11585

Issue Description

Commands and if available locally generated CW's are sent to the server, even without the Future Cacheex

When the issue occurs

from 11585

How the issue is reproducable

from 11585

camd35_send_extmode(struct s_client *cl);

Change History (8)

comment:1 by Unique, 5 months ago

2020/08/27 17:49:25 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:49:40 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:49:55 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:50:10 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:50:25 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:50:40 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:50:55 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:51:10 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:51:25 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:51:40 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:51:55 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:52:10 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:52:25 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:52:40 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:52:55 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:53:10 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:53:25 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:53:40 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:53:55 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:54:10 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:54:25 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:54:40 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:54:55 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:55:10 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:55:25 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:55:40 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:55:55 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:56:10 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:56:25 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:56:40 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:56:55 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:57:10 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:57:25 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:57:40 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:57:55 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:58:10 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:58:25 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:58:40 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32
2020/08/27 17:58:55 520E0C4B c   (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32

comment:2 by Opti, 5 months ago

this is the new future, a not switchable send unasked data to your opposite

comment:3 by Unique, 5 months ago

Resolution: fixed
Status: newclosed

is a bug and should be fixed soon

comment:4 by Unique, 5 months ago

Unfortunately I hoped that the comment in changeset 11585 was true
Unfortunately this was only used in conjunction with Cacheex and now you are surprised that it doesn't work properly without it
but one should not give up hope :-)

comment:5 by savan, 5 months ago

2020/08/27 17:57:40 520E0C4B c (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32

This error is strange since mbuf[0] sent from tvheadend was 80 in hex it is 0x50, but if you look into https://trac.streamboard.tv/oscam/browser/trunk/module-camd35.c#L964 on line 964 expected case need to be 0x50 but instead default case is processed, something is wrong with it, for example there is no break at the end of default switch! Just add break at the end of default case and bug will gone.

Last edited 5 months ago by savan (previous) (diff)

comment:6 by w33dburner, 5 months ago

a default-case doesnt need a break
the problem only occurs i the peer's version is < 11585.
fix is still waiting for feedback @ board => https://board.streamboard.tv/forum/thread/46549-l%C3%B6sung-f%C3%BCr-freezer-bei-09c4-cacheex/?postID=598986#post598986

comment:7 by savan, 4 months ago

Resolution: fixed
Status: closedreopened

Is mbuf isue fixed? I don't see any fix referencie but ticket is closed. Mbuf[0] is allready 80 and point to the wrong case which produce this:

2020/08/27 17:55:55 520E0C4B c (camd35) unknown [cs357x/cs378x] command from tvheadend! (80) n=32

Something is wrong there! Don't ignore!

Last edited 4 months ago by savan (previous) (diff)

comment:8 by erbas, 4 months ago

I need to agree with you @savan, I have the same problems with tvheadend!
@gorgone can we give this correction?
My thanks in advance.

Note: See TracTickets for help on using tickets.