Opened 3 months ago

Closed 12 days ago

#4861 closed enhancement (fixed)

CMakeLists.txt needs to be updated

Reported by: samur Owned by:
Priority: minor Component: General
Severity: low Keywords: CMakeLists.txt
Cc: Sensitive: no

Description

Reason for enhancement

<CMake Deprecation>

Possible impacts on other features

<Please fill in>

this line "cmake_minimum_required(VERSION 2.8.9)" in CMakeLists.txt need to be
updated to "cmake_minimum_required(VERSION 2.8.12)"

Log:

-- The C compiler identification is Clang 11.0.5
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working C compiler: /tmp/android-ndk-r22b/toolchains/llvm/prebuilt/linux-x86_64/bin/clang - skipped
-- Detecting C compile features
-- Detecting C compile features - done
CMake Deprecation Warning at CMakeLists.txt:5 (cmake_minimum_required):
  Compatibility with CMake < 2.8.12 will be removed from a future version of
  CMake.

  Update the VERSION argument <min> value or use a ...<max> suffix to tell
  CMake that the project does not need compatibility with older versions.

Change History (2)

comment:1 by samur, 3 months ago

Summary: CMakeLists.txt need to be updatedCMakeLists.txt needs to be updated

comment:2 by nautilus7, 12 days ago

Resolution: fixed
Status: newclosed

fixed in 11698

Note: See TracTickets for help on using tickets.