Opened 12 years ago

Closed 11 years ago

#59 closed defect (invalid)

Oscam crash when loading local cccam

Reported by: Levis Owned by:
Priority: critical Component: Protocol - CCCam
Severity: high Keywords:
Cc: Sensitive: no

Description

Oscam 534 with ipbox200s

All running ok, share is ok.
When I run the local cccam on server, sometimes I obtain this:

474 s PANIC: Cannot fork() (errno=12)
474 s exit with signal 1

If I kill cccam (2.1.3) and restart oscam all is ok. (with other clients)

I've run also with -d63 flag, but nothing more when it crash.
Sometimes it runs for 2-3 hours without problem also with local cccam but with no evident reason it crashes suddenly.

Tell me if you need other info.

Thank you for your great work.

Change History (11)

comment:1 by landlord, 12 years ago

Resolution: invalid
Status: newclosed

I can not reproduce it.

comment:2 by Eneen, 12 years ago

Resolution: invalid
Status: closedreopened

Same here:
2009-12-04 11:14:53 104 s PANIC: Cannot fork() (errno=12)
I happends sometimes after long run I think when user number is reaching max (29?)

comment:3 by Eneen, 12 years ago

Priority: majorcritical
Severity: mediumhigh

I can add that it happened while multiple reconnection tries to remote newcamd server, but earlier it happened while user was trying to connect. After that I have to restart DM500, cos restarting oscam causes same error almost every time user connect.

comment:4 by Eneen, 12 years ago

from log file:

2009/12/05 20:55:36 4318 s PANIC: Cannot fork() (errno=12)
2009/12/05 20:55:36 4318 s exit with signal 1

nothing more...

Most connections are CCcam from DM500.

comment:5 by Eneen, 12 years ago

I can add that it was happenning when other DM500 boxes and local CCcam were connected via newcamd. I've tested on camd3 and it went all clear. I can't confirm if removing local cccam helped, cos I reconfigured all connections to camd3 proto. Every DM500 and local CCcam were using 2 connections (2 CAIDs).

comment:6 by Eneen, 12 years ago

Allright it happened again, and local cccam was active. After crash cccam took contol over sci and oscam couldn't open it.

comment:7 by wolls, 12 years ago

Hallo, same problem for me, i use svn763 on ipbox 200s, this is the log when problem happens:

2009/12/20 18:58:48    194 c03 IPboxServer (093B&000000/2AAA/82:D6D6): not found (4989 ms)
2009/12/20 18:58:48    194 c03 Connection closed to client
2009/12/20 18:58:48    194 c03 IPboxServer disconnected from X.X.X.X
2009/12/20 18:58:48    172 s   PANIC: Cannot fork() (errno=12)
2009/12/20 18:58:48    172 s   exit with signal 1

Thanks!

comment:8 by wolls, 12 years ago

Hallo, today i tried to use only mgcamd for all clients and server, no cccam client but same problem. Now i'm using a very old oscam version, i don't know what, in oscam log it appear as:

version=0.99.4svn

i'll notice you if something NOT happens :)

comment:9 by alno, 12 years ago

Component: Protocol - CCCam
Resolution: fixed
Sensitive: unset
Status: reopenedclosed

comment:10 by krow, 11 years ago

Resolution: fixed
Status: closedreopened

this happens on latest version
using a VPS if load oscam only all goes well
if load oscam and then CCcam oscam gives the reported error
enven if I use sleep for process to load and take its time... if I restart oscam it crashes after a few seconds...

this happens only on VPS witg 1GB of memory (no swap)

on my pc (at home) this error does not happens

think SWAP plays a role in here...

on VPS we cant creat swap.. (even if we try manually)

comment:11 by Deas, 11 years ago

Resolution: invalid
Status: reopenedclosed

there has been a big change in the ocam architecture now. so please check again with the latest threaded version and reopen a new ticket with debug log.

Note: See TracTickets for help on using tickets.