Opened 12 years ago

Closed 12 years ago

#729 closed defect (invalid)

Oscam can not fork 2948

Reported by: zeri Owned by:
Priority: blocker Component: Protocol - CCCam
Severity: high Keywords:
Cc: Sensitive: no



When I run oscam with cca 44 CCcam clients immediatly after they start logging in I get error:

2010/08/23 12:36:50 25607 c36 cccam(s) : version: 2.1.4, build: 319 1 nodeid: 9CF26F8D1CFA7AC5
2010/08/23 12:36:50 25607 c36 cccam(s) : reported 19 cards to clien t
2010/08/23 12:36:50 25608 c42 encrypted cccam-client granted (kra ko, au=0)
2010/08/23 12:36:50 25610 c44 cccam(s) : client is using version 2. 0.11 rc4
2010/08/23 12:36:50 25610 c44 encrypted cccam-client granted (user 19, au=0)
2010/08/23 12:36:50 24492 s PANIC: Cannot fork() (errno=12)
2010/08/23 12:36:50 24492 s exit with signal 1

Streamboard SVN: 2948

Change History (6)

comment:1 by alno, 12 years ago

please post the content of your /tmp/oscam.version

comment:2 by zeri, 12 years ago

Severity: mediumhigh

xstarttime: 1282557139
starttime: 23.08.10 13:52:19
version: 0.99.4svn#2948
maxpid: 512
webifsupport: yes
dvbapisupport: yes
gboxsupport: no
anticascsupport: yes

comment:3 by alno, 12 years ago

On which kind of system you run oscam? Cannot fork normally occurs when a machine runs out of memory.

comment:4 by zeri, 12 years ago

it's being run on Debian lenny with 1gb ram and 1gb burst ram - vps server

comment:5 by lattjo, 12 years ago

Some google searching and it looks like a problem with the vps. Kmemsize could be the problem,, if so it must be solved by the vps host.

comment:6 by zeri, 12 years ago

Resolution: invalid
Status: newclosed

Allright, you were right I ran it on my pc at home and it works


Note: See TracTickets for help on using tickets.